Very annoying

jeffm

New Member
Joined
May 23, 2009
Messages
2
Reaction score
0
Hi All, Just started to get a problem when i start our 2001 E class. The starter motor turns over but won't start the engine.Tried 7 or 8 times , nothing. Yellow engine diagnostic indicator light stays on when car eventually starts.Then was ok for a few hours then starts playing up again.

Seems to be getting more frequent. Could it be something to do with immobilisor ?
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
331
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Hello and welcome diesel or petrol please, also 210 or 211
 
OP
J

jeffm

New Member
Joined
May 23, 2009
Messages
2
Reaction score
0
  • Thread Starter
  • Thread starter
  • #3
Hello Mate , Its a petrol engined E240 Elegance. Auto.
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
331
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Crank shaft sensor I would have said, the light throws me a little,, when this fails the car often starts ok, and stops when it is warm, then the cycle repeats itself
 


The SL SHOP YOUR ONE STOP SHOP FOR ALL THINGS SL, SERVICE & RESTORE, SALES, HIRE & PARTS
Choose from a wide range of superbly prepared SL’s each with a 12 month guarantee. We can service, update, re-trim, restore and repaint your 107 SL.
Choose from a 6 or 8 cylinder car for the day, the weekend, a month or a year. Contact us for a wide range of parts. Tel: 0844 414 2116 or visit our website atwww.theSLshop.com
Top Bottom