Viano 2008 3.0 v6 random power loss

Not-a-mechanic

New Member
Joined
Feb 19, 2020
Messages
6
Reaction score
0
Your Mercedes
Viano 08 3.0 v6
Hi, if anyone can share some light. I have a 2008 viano 3.0 v6. 170,000 miles on it .
Previous owner 1 year ago put a new turbo on , I have since change oil, new transmission , air filter , fuel filter, new maf sensor and two new turbo pressure sensors.
it still has a problem. Even merc dealer couldn’t find the problem.
the problem is when I am driving at speed. 70 mph and holding for some time on the motorway then I go to either accelerate or slow down down then accelerate it has a loss of acceleration . You put your foot to the floor and it will creep up to about 80 after a minute or two as long as no hills are around. It is an automatic . The mechanic though the transmission was the fault but it is still occurring. This problem sometimes occurs when going at low speeds as well . Some days when going around town it hesitates a few seconds too long to speed up then goes like a rocket .
no check engine lights at all ever. No smoke. No knocking .
doing research I have checked play on turbo and seems to be fine . The inlet tube rubber seal is a bit mashed up and provides a pretty good seal with the clamp and pipe.
Should be checking the inter cooler pipe? As I’m not sure if this was changed when turbo was replaced? Accelerator sensor? throttle pressure sensor!
does anyone know of any tests I can do ? Or anyone have had the same issue.
Any help or advice would be appreciated.
 

Larkone

Senior Member
Joined
Aug 19, 2016
Messages
926
Reaction score
889
Location
NW Essex
Your Mercedes
C219 CLS 320CDI 2008
Turbo actuator going - was it replaced with the new turbo?
 
  • Like
Reactions: M80
OP
N

Not-a-mechanic

New Member
Joined
Feb 19, 2020
Messages
6
Reaction score
0
Your Mercedes
Viano 08 3.0 v6
  • Thread Starter
  • Thread starter
  • #3
Hi thank you for your response . I have managed to speak to the old owner and I also read the invoice of what his old mechanic had done.
It was a new turbo charger £642 it doesn’t say if an actuator was with it. His mechanic found a fault in the intake manifold system so he stripped out manifold motor and replaced parts. He also cleaned out oil of intercooler hoses.he also fitted a viano 2.1 battery in it. ( He had to pay £1670.00.
Then he sold it to me!!
 

alexanderfoti

MBO Forum Supporter
Authorised Forum Supporter
Joined
Mar 25, 2010
Messages
15,165
Reaction score
6,351
Location
Tonbridge
Your Mercedes
W221 S65 AMG - W204 C63 AMG + Various other MB's
Sounds like it's in limp mode intermittently. It needs plugging into a good diagnostics reader and the historic codes read.

There will be freeze frame data if it's intermittently going into limp mode.
 
OP
N

Not-a-mechanic

New Member
Joined
Feb 19, 2020
Messages
6
Reaction score
0
Your Mercedes
Viano 08 3.0 v6
  • Thread Starter
  • Thread starter
  • #5
Hi, I am not that familiar with limp mode but it will allow me to rev over 3000 but acceleration is like a snail.
This morning is the first time ever it has a check engine symbol on the dash.
My mechanic who wants it back is 40 mins away , he’s a transmission specialist and has the diagnostic tools. He is annoyed as he thought it was the transmission and after charging me for a new one £3000 I’m still in the same place!
 
OP
N

Not-a-mechanic

New Member
Joined
Feb 19, 2020
Messages
6
Reaction score
0
Your Mercedes
Viano 08 3.0 v6
  • Thread Starter
  • Thread starter
  • #6
As we have been chatting I have been taking it out for a spin.
Half an hour ago I unplugged the sensor on top of the accelerator pedal . Dash showed esp fault go to work shop. Then I did a transmission reset and left it for a few minutes before driving. Now driving it it is completely different on the throttle response. You put your foot down and it steadily increases in rev and speed nothing fast but no where near limp mode. Once you get to 3200 revs it feels like turbo kicks in more and you accelerate a lot more. usually I would be able to pull over and turn it all off and go like hell again but now it just drives the same. Still have check engine light.
 

roderick gregg

New Registration
Joined
Aug 6, 2020
Messages
1
Reaction score
0
Your Mercedes
2010 Viano v6
Hi, I have been having a similar issue since getting my V6 Viano - Could you please tell me how you performed the transmission reset on yours. Thanks
 
OP
N

Not-a-mechanic

New Member
Joined
Feb 19, 2020
Messages
6
Reaction score
0
Your Mercedes
Viano 08 3.0 v6
  • Thread Starter
  • Thread starter
  • #8
Hi, the transmission reset did nothing. In the end I found a mechanic who was a mechanic not a ‘Diagnostics says nothing is wrong ‘ and didn’t mind figuring it out with experience and tools. It was the throttle body in the end. Running great now as i have done 30,000 miles since October. Just wear and tear usually parts to replace now.
 
Top Bottom