1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

vito wont rev above 2500 since gearbox repair?!?

Discussion in 'Engine, Drivetrain, Fuel and Exhaust' started by liamvito, Nov 3, 2012.

  1. liamvito

    liamvito New Member

    Messages:
    4
    Likes Received:
    0
    Joined:
    Nov 3, 2012
    Location:
    southampton, hampshire,england
    Your Mercedes:
    VITO 110 CDI 2001
    Hi all, I wonder if anyone can help me get my Vito running back to its old self. It's a Vito 110 cdi 51 reg. I recently lost 2nd gear so put it in for repair, but since I've got it back its lost a lot of power when I put my foot down and won't rev above 2500.

    Could this be related to the gearbox repair or is it something totally separate.

    Id be gratefull of any help on this.

    Many thanks
     
  2. Alex Crow

    Alex Crow Senior Member

    Messages:
    10,677
    Likes Received:
    28
    Joined:
    Jul 9, 2009
    Location:
    Super Suffolk
    Your Mercedes:
    W169, W124, w202, W203, KTM 250 EXC, VW T25 camper and a Polo in a pear tree
    What did the gearbox people say?
    Assuming you will have spoken to them first, if not, do!
     
  3. television

    television Always remembered RIP

    Messages:
    164,074
    Likes Received:
    277
    Joined:
    Mar 14, 2005
    Location:
    Daventry
    Your Mercedes:
    2002 SL500, 216 CL500, all fully loaded
    If the power output from the engine is down the gearbox will not change correctly
     
  4. OP
    liamvito

    liamvito New Member

    Messages:
    4
    Likes Received:
    0
    Joined:
    Nov 3, 2012
    Location:
    southampton, hampshire,england
    Your Mercedes:
    VITO 110 CDI 2001
    Will have to wait untill Monday to speak to the gearbox guy. Hopefully there's a simple solution
     
  5. Steve@Avantgarde

    Steve@Avantgarde Forum Supporter Authorised Forum Supporter

    Messages:
    6,808
    Likes Received:
    960
    Joined:
    Dec 8, 2009
    Location:
    Bristol/Somerset
    Your Mercedes:
    C220CDI AMG Line Premium, SLR McLaren Roadster, SL55 & C32AMG
    Check to see if the pressure sensor pipe has been disconnected and not refitted, sits on the front bulkhead area.
     
  6. OP
    liamvito

    liamvito New Member

    Messages:
    4
    Likes Received:
    0
    Joined:
    Nov 3, 2012
    Location:
    southampton, hampshire,england
    Your Mercedes:
    VITO 110 CDI 2001
    Thanks ill check that out
     

Share This Page