w123 sudden central locking failure after water pump

TotallyImpractical

Active Member
Joined
Nov 3, 2008
Messages
41
Reaction score
0
Location
Birmingham
Your Mercedes
1985 230E w123
Dear Gang,

I am a neophyte in dealing with the vacuum system so am relying on you all to point me in the right direction.

Just got the car back from the local garage after having a new water pump, radiator, gearbox lines only to suddenly have no central locking.

Perviously, the central locking worked perfectly. This is a 1985 230E, 145,000 miles

Now, nothing! No sound, no hissing noise, no movement....I can only manually unlock the driver's door with a key.

Could they have knocked something loose or disconnected something controlling the central locking whilst installing the water pump/radiator?

Or is this sheer coincidence?

Thanks in advance,

Marian
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Yes they will have knocked off a vacuum pipe, either on the engine or one of the valve blocks, or could be one of the headlamp pipes that raise and lower them
 
OP
TotallyImpractical

TotallyImpractical

Active Member
Joined
Nov 3, 2008
Messages
41
Reaction score
0
Location
Birmingham
Your Mercedes
1985 230E w123
  • Thread Starter
  • Thread starter
  • #3
Thanks for the quick reply. The local independent just confirmed that and warned me not to take it back to them to fix since they wouldn't know what they did anyway!

Incidentally, is it bad to drive the car until I get it fixed?
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Thanks for the quick reply. The local independent just confirmed that and warned me not to take it back to them to fix since they wouldn't know what they did anyway!

Incidentally, is it bad to drive the car until I get it fixed?

Not at all but the idle may be slighly on the fast side depending on where the pipe is off.

You could look under the bonnet for a loose plastic pipe

You can see them in the links. And they only push on


http://www.detali.ru/cat/oem_mb2.as...+++717.401&CT=F&cat=318&SID=80&SGR=015&SGN=01

The middle picture here

http://www.detali.ru/cat/oem_mb2.as...+++717.401&CT=F&cat=318&SID=80&SGR=045&SGN=02
 


ALL MBO Club members qualify for 15% discount on second hand parts.Please see MBO Members’ Area for discount codewww.dronsfields.com
Top Bottom