W124 320Ce indicator fault

jibcl500

Senior Member
Joined
Oct 22, 2005
Messages
6,420
Reaction score
8
Age
55
Location
Cambridgeshire
Your Mercedes
CL500,ML55,SLK280
All

just had a call from my father, he drives a 1994 W124 320CE and he mentioned tonight the indicators dont flash on the dash to show the direction but work perfectly otherwise, also no other faults to be reported.
Anyone seen this or knows what it could be?

jib
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
364
Age
88
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
These are wired in parallel to the blinkers, and can only be the connection on the cluster i would have thought. from memory they go to the 2 end pins

Is it the same on hazard
 

Cole@MBS

Forum Supporter
Authorised Forum Supporter
Joined
Dec 1, 2008
Messages
13,702
Reaction score
945
Age
53
Location
Southampton
Website
www.mbssouthampton.co.uk
Your Mercedes
124 300 CE 24 Coupe, C220CDI, Porsche 911 4s, Dolomite sprint,
Seen a 202 Jib do this, needed a new cluster, dont now if a 124 would be anything like a 202 one but who knows........................

One things for sure, both bulbs wont have gone at the same time!! would/could they???
 
OP
jibcl500

jibcl500

Senior Member
Joined
Oct 22, 2005
Messages
6,420
Reaction score
8
Age
55
Location
Cambridgeshire
Your Mercedes
CL500,ML55,SLK280
  • Thread Starter
  • Thread starter
  • #4
Could be possible both bulbs failed at the same time but I wouldnt think so, cluster failure possibly, what about relays?!

jib
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
364
Age
88
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Could be possible both bulbs failed at the same time but I wouldnt think so, cluster failure possibly, what about relays?!

jib

There are no relays in this
 

meanie

Senior Member
Joined
May 7, 2008
Messages
581
Reaction score
0
Location
Oxon
Pins 14 & 15 are the indicator wires (black & white/green respectively).
Sods law says that you've chucked the one off your breaker?!?
 

star

Forum Supporter
Authorised Forum Supporter
Joined
Oct 6, 2004
Messages
6,199
Reaction score
1,843
Location
Reading
Your Mercedes
Smart + others :)
the flasher relay is combines with the wiper delay relay in the main fuse box. bout the size of a packet of cigs but if all are working apart from dash, check bulb in dash 1st.
 
OP
jibcl500

jibcl500

Senior Member
Joined
Oct 22, 2005
Messages
6,420
Reaction score
8
Age
55
Location
Cambridgeshire
Your Mercedes
CL500,ML55,SLK280
  • Thread Starter
  • Thread starter
  • #8
spoke to father again today and as it turns out there are no lights working on the dash with the key in position two!!! So I think I can assume the cluster is faulty.

jib
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
364
Age
88
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
spoke to father again today and as it turns out there are no lights working on the dash with the key in position two!!! So I think I can assume the cluster is faulty.

jib

You have WIS take a peep at the wiring and see if there is a fuse, other than that it can only be a PCB fault or connection
 
OP
jibcl500

jibcl500

Senior Member
Joined
Oct 22, 2005
Messages
6,420
Reaction score
8
Age
55
Location
Cambridgeshire
Your Mercedes
CL500,ML55,SLK280
  • Thread Starter
  • Thread starter
  • #10
You have WIS take a peep at the wiring and see if there is a fuse, other than that it can only be a PCB fault or connection

I think its most likely to be the cluster, I have one in stock from a 320TE that ive just broken so will try that for him and see how it goes.

jib
 


www.W140.co.uk&www.r129.co
Specialist in parts for W140 and R129 Mercedes-Benz models.
Top Bottom