W124 coupe rear window regulator?

richardmorris

Senior Member
Joined
Apr 8, 2012
Messages
98
Reaction score
0
Location
Surrey
Your Mercedes
1994 E320 coupé
hello,

Long time since I’ve posted but the car has been trouble free until now. I’ve just got home and decided to open all the windows and roof to give it an airing in the sun ( car let in water when the snow melted).
All open fine apart from the n/s rear which just gives a click when the switches ( either console or door card) are pressed. No movement is attempted.

Any thoughts? Are the regulators troublesome or the motors themselves?

Thanks,

Richard
 

LostKiwi

Senior Member
Joined
Aug 25, 2006
Messages
26,591
Reaction score
16,091
Location
Midlands / Charente-Maritime
Your Mercedes
'93 500SL-32, '01 W210 Estate E240, 02 R230 SL500 (Malcolm Spec), 04 Smart Roadster Coupe
hello,

Long time since I’ve posted but the car has been trouble free until now. I’ve just got home and decided to open all the windows and roof to give it an airing in the sun ( car let in water when the snow melted).
All open fine apart from the n/s rear which just gives a click when the switches ( either console or door card) are pressed. No movement is attempted.

Any thoughts? Are the regulators troublesome or the motors themselves?

Thanks,

Richard
http://forums.mercedesclub.org.uk/i...gulators-possibly-others.167593/#post-1608683
 
OP
richardmorris

richardmorris

Senior Member
Joined
Apr 8, 2012
Messages
98
Reaction score
0
Location
Surrey
Your Mercedes
1994 E320 coupé
  • Thread Starter
  • Thread starter
  • #3
Hi, I saw that post, but it didn’t describe the problem mine has.
It was working ok on that side, although it always had a clunk about halfway up the eccentric movement. Now it just doesn’t move at all.
 

LostKiwi

Senior Member
Joined
Aug 25, 2006
Messages
26,591
Reaction score
16,091
Location
Midlands / Charente-Maritime
Your Mercedes
'93 500SL-32, '01 W210 Estate E240, 02 R230 SL500 (Malcolm Spec), 04 Smart Roadster Coupe
My 129 did that on the driver's door. The motor had come off mounts and was jamming on the quadrant. Pretty much what happened on that other post.
 
OP
richardmorris

richardmorris

Senior Member
Joined
Apr 8, 2012
Messages
98
Reaction score
0
Location
Surrey
Your Mercedes
1994 E320 coupé
  • Thread Starter
  • Thread starter
  • #5
Thanks, I’ll get the panel off tomorrow and have a look before buying anything.
 
OP
richardmorris

richardmorris

Senior Member
Joined
Apr 8, 2012
Messages
98
Reaction score
0
Location
Surrey
Your Mercedes
1994 E320 coupé
  • Thread Starter
  • Thread starter
  • #6
Well it started working on its own. Now it’s stopped snowing I’ll take the panel off and look at the mechanism.
 

LostKiwi

Senior Member
Joined
Aug 25, 2006
Messages
26,591
Reaction score
16,091
Location
Midlands / Charente-Maritime
Your Mercedes
'93 500SL-32, '01 W210 Estate E240, 02 R230 SL500 (Malcolm Spec), 04 Smart Roadster Coupe
The glass wasn't frozen to the rubbers was it?
 
OP
richardmorris

richardmorris

Senior Member
Joined
Apr 8, 2012
Messages
98
Reaction score
0
Location
Surrey
Your Mercedes
1994 E320 coupé
  • Thread Starter
  • Thread starter
  • #8
If only!

No, it was under cover and a warm sunny afternoon. It is still clunky at the top of the eccentric movement though- like it’s catching on something.
 

Use the code MERCEDES and get 10% MBO Club Discount, oilman's website:www.opieoils.co.uk

register for news and offers email:sales@opieoils.co.ukphone: 01209 202944
Top Bottom