W124 wipers not working

benster

Active Member
Joined
Dec 9, 2012
Messages
44
Reaction score
2
Location
london
Your Mercedes
E220 estate 1996
Hello all, I need some help, my wipers have stopped working, I can hear the N10 relay clicking, but nothing works, it had a new wiper motor fitted last year, I’ve read that the N10 controls the intermittent wipe but does this relay control the normal and fast wipe, any help would be appreciated.
 

Al Smith

Active Member
Joined
Jan 4, 2013
Messages
44
Reaction score
7
Location
Nottinghamshire
Your Mercedes
C43 estate 2017 E270 cdi estate 2006
Hi Benster....if it's any help at all, i had the same problem on my 1994 e320 and I found that the relay was not seating properly.By moving it in the base I found where contact was being made and then wedged it in place with plastic shims. I am no mechanic ,but this worked for me.
 

d215yq

Senior Member
Joined
Mar 28, 2008
Messages
2,664
Reaction score
702
Age
40
Location
Valencia, Spain
Your Mercedes
1987 W124 300D 280k miles
Dodgy fuse 2 caused this on mine. Although that fuse powers lots of other stuff it had just a good enough connection for everything to work but not enough for the wipers, the relay's were just clicking/whirring but no action.
 
OP
B

benster

Active Member
Joined
Dec 9, 2012
Messages
44
Reaction score
2
Location
london
Your Mercedes
E220 estate 1996
  • Thread Starter
  • Thread starter
  • #7
Thank you for all your reply’s, I will check the fuses and the holders, and try wiggling the relay, and let you know what solves it thanks again
 

d:class automotive are specialists in automotive interiors and upholstery. From Mercedes and modern cars to custom and classics. Tel: 01483 722923 Email:info@dclass.co.ukWeb:www.dclass.co.uk
Top Bottom