W140 cold air only

C

C180 Chris

Guest
Hi Again,

The other snag with my S320 is that the heater blows only cold air out.
So far i have read about the duo valves causing this type of fault, does it sound right for a duo valve fault and are they the large block behind the N/S front lights on a S320?
( pipes seem to go toward bulkhead)

Also another question..
My car is a '96 'N' plate car and is as such fitted with the later air con/ blower panel, could anyone please direct me to some instructions on how to use it and how to get the twin air con fans up and spinning from the panel.

All the very best,
 
OP
C

C180 Chris

Guest
  • Thread Starter
  • Thread starter
  • #3
Thanks again Malcolm,

I will have a sniff around that unit in the coming days and report my findings.
I have found some loose fuses lying in the ash tray! ( wonder if the last owner has tried a bit of DIY, everything else seems to work ok except the passenger seat backrest and headrest adjustment)

Many thanks,
 

shayes

Senior Member
Joined
Oct 10, 2002
Messages
1,051
Reaction score
3
Your Mercedes
as stated
Duo valves normally fail in the hot mode, so not that with luck there is a pump on the unit, and it could be that

8 and 14

Picking up on this old thread. Both my duo valves are on the fault code, and the Air con Pressure reading is zero. Valves Open on hot, as you say Malcolm as only getting warm air through the vents on Lo setting. So No doubt a leak which perhaps is causal (?) to valves.
I'm thinking of putting in a can of R134a + sealant. OK technically I should try to discover why no pressure and I have no idea as to the quantity of gas needed for the system. There is no quantity data as far as I can see in the hand book. Anybody know what the quantity is, is it just pressure related? Will I need one or two or three cans? Guess I will need to take a read out after putting in a can.

I recognise from anothers very interesting thread that this is an expert subject and should
entrusted to someone competent to do a thorough check to establish leaks. Fact is, only Cowboys around here and I recall paying £150 to someone to regas the MR2 only to discover following year, zilch air con.
Temporary fixes tend to suit me, I have to be honest. At £20 if I get through the Summer, cool, thats fine. Based on past experience I can get at least seven Summers and still be £10 in rather than going to honest joe the Air con man.
 

shayes

Senior Member
Joined
Oct 10, 2002
Messages
1,051
Reaction score
3
Your Mercedes
as stated
Went to K-F (I know I know) and they fixed up the machine and I left them to it, supposedly sucking out, and sending in sealant and gas. Cold air now, so duo valves presumeably now working (thank you Malcolm) and service unnecessary. Will monitor and drive with fingers crossed.

(May do another read out to see what codes come up, out of interest.)
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
331
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Went to K-F (I know I know) and they fixed up the machine and I left them to it, supposedly sucking out, and sending in sealant and gas. Cold air now, so duo valves presumeably now working (thank you Malcolm) and service unnecessary. Will monitor and drive with fingers crossed.

(May do another read out to see what codes come up, out of interest.)

I missed this post Stuart,,, if the hot air is not good the the recirculation pump will be at fault,,pleased that you are cool now anyway
 

shayes

Senior Member
Joined
Oct 10, 2002
Messages
1,051
Reaction score
3
Your Mercedes
as stated
I missed this post Stuart,,, if the hot air is not good the the recirculation pump will be at fault,,pleased that you are cool now anyway

You have an uncanny way of knowing in advance what to expect Malcolm. I'm always impressed. Tried the car from cold and checked the fault codes again. No duovalve problem code showing but Eb1416 for Coolant Circulation pump now showing. I'll have to try to get hot air next time I'm out and the cars up to temperature. Will this make a difference or should I start to consider options for a new /s/h pump? Suspect that this means another gas re-charge if faulty. Did not show up as error code when no pressure in system.
 
Last edited:

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
331
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
This is nothing to do with the air con,,only the water cooling section,,there will hardly be any coolant loss to change it,,have a word with jib he knows where the S/H 140 parts can be got from,, try rob parker,, this could be the same pump as in many other cars including the 129 or 210
 
OP
C

C180 Chris

Guest
  • Thread Starter
  • Thread starter
  • #9
Try Carl at w140.co.uk, he is first rate!
 

shayes

Senior Member
Joined
Oct 10, 2002
Messages
1,051
Reaction score
3
Your Mercedes
as stated
Thanks Chris, I've been buying from Carl for some time. Its knowing which part you need that is the problem. Now eliminated duovalves and trying to determine if Regulator, or stuck flap. Plenty of fan but only to one side of windscreen on hot. Have to do more checks If latter, need to see exploded diagram to discover how complicated to check. Fault code now eb1416 which is engine coolant pump motor but not trusting this as can get hot and cold from system.
More research or patience needed.
 
Top Bottom