W163 ML320 BAS ESP light

pjn11

New Member
Joined
Apr 15, 2009
Messages
7
Reaction score
0
Hi all, I have the ESP/BAS light on every thing works ie cruise, brake lights etc, the only thing Ive noticed is that I cant turn the ESP off has anyone got an idea as I havent.

Thanks Paul
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
331
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Do change the brake light switch that sits above the brake pedal, only cost around £10
 

niterider

Active Member
Joined
Aug 31, 2008
Messages
36
Reaction score
0
Age
64
Location
Huntingdon
I also have the same light on I have replaced the switch you mention to no avail. Also occasionally when I am going round a bend to the left ( left hand down on steering wheel) I get avibration as if the ABS is trying to work on the drivers front wheel but I have no loss of use of the brakes. It's just ****** frightening when it happens and I beleive that when this light is on ABS is not working , but one of you guy's will confirm that or tell me otherwise I am sure.

Regards

Dave niterider
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
331
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
It could be just the sensor somewhere,, even if the ABS fails you still have normal brakes,,once again plugging into STAR will tell you what the problem is
 

niterider

Active Member
Joined
Aug 31, 2008
Messages
36
Reaction score
0
Age
64
Location
Huntingdon
I take it star is the Merc computer?, because I paid £54 to mercs in Peterborough and was told I need a gearbox electrcal plate at a cost of around £500.00 inc vat. As I work for DHL I took an Actros to inter county (a merc dealer for HGVs) and the night foreman says he maybe able to look up and see what the problem is although he can only look at certain bits due to the fact that they deal mainly with HGVs.

Do you have any other suggestions?.

Regards

Dave niterider
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
331
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Yes the plate could cause the fault,,£320 from an indie,
 
OP
P

pjn11

New Member
Joined
Apr 15, 2009
Messages
7
Reaction score
0
  • Thread Starter
  • Thread starter
  • #7
I have had it plugged in, and it has got the steering angle sensor fault not done anything about it yet to scared to find out how much.
 

niterider

Active Member
Joined
Aug 31, 2008
Messages
36
Reaction score
0
Age
64
Location
Huntingdon
I still haven't got my light problem sorted but I took the ML to intercounty the other night as I was talking to the night foreman when I took a company Actros in for serviceing and he ran the computer over my ML and it came up witha load of stored faults, as we were chatting he suddenly asked if I had had the tracking done? yes says I but not by Merc dealer but aBMW speacialist and he explained hoe the Mercs have a set up and if this is not done 100% this could also bring this light on. Any way he knows the foreman in the local workshop who has said he is going to have a look at it on a Saturday morning soon. So heres hoping it might just need the tracking done .
 

Hertfordshire Merx

Senior Member
Joined
Feb 16, 2009
Messages
353
Reaction score
0
Your Mercedes
A160
I still haven't got my light problem sorted but I took the ML to intercounty the other night as I was talking to the night foreman when I took a company Actros in for serviceing and he ran the computer over my ML and it came up witha load of stored faults, as we were chatting he suddenly asked if I had had the tracking done? yes says I but not by Merc dealer but aBMW speacialist and he explained hoe the Mercs have a set up and if this is not done 100% this could also bring this light on. Any way he knows the foreman in the local workshop who has said he is going to have a look at it on a Saturday morning soon. So heres hoping it might just need the tracking done .

Huntingdon is not far from me, if you like give me a call and I can check it out properly for you and advise accordingly...
 

basharv

Member
Joined
Oct 15, 2007
Messages
10
Reaction score
0
Your Mercedes
ML 350 (03) runs on LPG
I had this recently, but the light was intermittant. I had a MOT and one of the lower front ball joints needed replacing. This had also caused excessive wear on the inside of the tyre. As soon as I replaced the tyres, the fault has not reappeared.
 


Mercedes-Benz Servicing, repairs, engine and diagnostics
Wayne Gates - Mercedes-Benz, Unit F3, Phoenix Industrial Estate, Rosslyn Crescent, Harrow, Middlesex, HA1 2SP
Tel: 020 8863 9233
Established for 20 years all vehicles washed and vacuumed.
Top Bottom