W202 a few small problems

momomo

Member
Joined
Aug 14, 2006
Messages
22
Reaction score
0
Your Mercedes
W221, W211, W202
Hi everyone,

Its a facelift W202 and a few niggles that im trying to sort out...

Firstly when the radio is on and the rear screen demister is turned on the radio instantly cuts out and only static is heard. I know the aeial runs down on the rear, the two strips but not sure why the demister would interfere? Any ideas anyone?

Secondly the heater control has a bulb gone. Now what is the easiest way to change the bulb on these. Pulling the bulb off i dont think will give me access. Will the trim panel have to be lifted off and the heater control unit unscrewed out and the bulb changed like that?

Finally on the heater control fan speed knob on other 202s the 0 setting switches the fan off and closes the vents, then after that there is the setting which opens the vents but the fan stays off and then 1-5 which turn the blower motor on at different speeds. For some reason the blower motor switches on and runs on the setting after 0 which im sue should just open the vents for air but not turn on the fan. Am i right?

Many Thanks in advance
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
The rear window will have open circuit track that set up the interference,,but owing to high current drawn by this unit, I would clean the N10 relay contacts and fuses that drive this with a good non drying switch cleaner.

On some cars a very large cap is added to the rear screen to suppress the noise

If the heater fan motor is only running at the slow speed,,it needs a new reg pack for the fan motor

Yes you can change the bulbs in the control unit by pulling off the knob and removing the bulbs with a large straw
 

type49

Senior Member
Joined
Jul 9, 2005
Messages
1,601
Reaction score
1
There is a large earthing point for the HRW on one of the C pillars (cant remember with side) Either way, this comes loose & gives poor reception, mainly on FM.
 

turbopete

Senior Member
Joined
Feb 4, 2009
Messages
14,204
Reaction score
328
Age
46
Location
Spennymoor
Your Mercedes
2010 '60' Ford Mondeo 2.0TDCi Zetec (sorry)
not sure if this would apply to a merc, but when i worked at a ford dealership we came across this a few times and found it was the earth for the signal amplifier or the amplifier itself that was a fault!
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
not sure if this would apply to a merc, but when i worked at a ford dealership we came across this a few times and found it was the earth for the signal amplifier or the amplifier itself that was a fault!

This is in the same place in C pillar,,so very near to the interference source
 

type49

Senior Member
Joined
Jul 9, 2005
Messages
1,601
Reaction score
1
not sure if this would apply to a merc, but when i worked at a ford dealership we came across this a few times and found it was the earth for the signal amplifier or the amplifier itself that was a fault!

Could well be the amp but checking if a 10mm nut is tight has got to be the first port of call :D
 

turbopete

Senior Member
Joined
Feb 4, 2009
Messages
14,204
Reaction score
328
Age
46
Location
Spennymoor
Your Mercedes
2010 '60' Ford Mondeo 2.0TDCi Zetec (sorry)
very true. just thought id throw another idea into the mix though, since its a fault ive come across before!
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
very true. just thought id throw another idea into the mix though, since its a fault ive come across before!

In my early days here this was a common problem on cars like the 126 with very curved rear windows, the interference was than caused by arcing in the demister print,,there were also kits where you could repair the screen tracks, but getting to the rear screen on those cars is near impossible.

The cure then was also to wire the screen to an18 volt supply and leave it on for several hours
 

turbopete

Senior Member
Joined
Feb 4, 2009
Messages
14,204
Reaction score
328
Age
46
Location
Spennymoor
Your Mercedes
2010 '60' Ford Mondeo 2.0TDCi Zetec (sorry)
In my early days here this was a common problem on cars like the 126 with very curved rear windows, the interference was than caused by arcing in the demister print,,there were also kits where you could repair the screen tracks, but getting to the rear screen on those cars is near impossible.

The cure then was also to wire the screen to an18 volt supply and leave it on for several hours

18 volts? sounds painful! :shock::shock::lol::lol::lol::lol:
 
OP
M

momomo

Member
Joined
Aug 14, 2006
Messages
22
Reaction score
0
Your Mercedes
W221, W211, W202
  • Thread Starter
  • Thread starter
  • #10
This is in the same place in C pillar,,so very near to the interference source

Thanks for the helpful suggestions, i will be taking a look at this when i can sometime soon.

In regards to the fan Malcolm its not on all the time or just at low speed, it works as it should and switches off when put to 0. Im sure your familiar with the fan speed dial on the w202. The only weird thing im finding is when i the put the dial to the setting after the 0 setting ( its not 1 speed but the one in between 1 and 0 which if i recall just opens the vents to let in air) the fan comes on when im sure it shouldnt. I have another 202 and the fan stays off on this setting as it should but seems to come on on this car. Im quite sure its not meant to, can anyone confirm.

I hope thats more clear

Many Thanks

Found a picture http://static.flickr.com/92/242393399_4417b1295e.jpg

You can see the setting between 0 and 1 whihc i am referring to. Im sure the fan is not meant to turn on on this setting but it does for some reason...
 
Last edited:
OP
M

momomo

Member
Joined
Aug 14, 2006
Messages
22
Reaction score
0
Your Mercedes
W221, W211, W202
  • Thread Starter
  • Thread starter
  • #11
In regards to changing the bulb Malcolm i thought i could pull the knob off and change it aswell but am having difficulty even seeing the bulb.

Ive been through this post
http://forums.mercedesclub.org.uk/showthread.php?t=26199&page=3

You can see Bazzle's post, #24, the inside is different to mine with the knob off. Funny tho, my other 202 looks exactly as bazzles with the knob off.

Ill see if i can get a picture tomorrow.
 
Last edited:

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
There is only the little round hole on some,,you will see it :D
 

turbopete

Senior Member
Joined
Feb 4, 2009
Messages
14,204
Reaction score
328
Age
46
Location
Spennymoor
Your Mercedes
2010 '60' Ford Mondeo 2.0TDCi Zetec (sorry)
i think theyre similar to the 210 set up. i had a bulb out behind my heater controls and theres a flap that opens to access the bulb that im not sure was present on earlier versions
 
OP
M

momomo

Member
Joined
Aug 14, 2006
Messages
22
Reaction score
0
Your Mercedes
W221, W211, W202
  • Thread Starter
  • Thread starter
  • #14
-------------
 
Last edited:
OP
M

momomo

Member
Joined
Aug 14, 2006
Messages
22
Reaction score
0
Your Mercedes
W221, W211, W202
  • Thread Starter
  • Thread starter
  • #15
Ah this sounds similar to my one. How does this flap open? Ive had a quick look but havent had much time to fiddle around with it yet!

And im still pondering about the issue with the fan speed knob setting i mentioned in post 10. Anyone with any ideas on this?

Many Thanks
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
The flap is only a diffuser, and lifts away
 

turbopete

Senior Member
Joined
Feb 4, 2009
Messages
14,204
Reaction score
328
Age
46
Location
Spennymoor
Your Mercedes
2010 '60' Ford Mondeo 2.0TDCi Zetec (sorry)
flap just flips open with a very small screwdriver or similar object
 
OP
M

momomo

Member
Joined
Aug 14, 2006
Messages
22
Reaction score
0
Your Mercedes
W221, W211, W202
  • Thread Starter
  • Thread starter
  • #18
Thanks for the replies guys. Found a bit of time yesterday to get the old bulb out. Yes the flap does lift away, it actually looked like it would snap if lifted away but it didnt. Managed to get the old bulb out after alot of headache!

Hopefully will get a bit a time today after work to have a go at the c pillar and see if i can fix this interference problem
 

Mikimogo

Senior Member
Joined
Feb 26, 2007
Messages
79
Reaction score
0
Location
Alsager, Stoke-on-Trent, Staffordshire
Your Mercedes
Mercedes C220 CDI Yr2000 w202 engine 611960 (OM611)
Hi,
Sorry to jump in but I've got the same car with some faults that some of you guys are helping me with but I too have the Radio/RWH interferrence problem. The N10 Relay was mentioned, could someone please tell me where this lives.:Oops:
 
OP
M

momomo

Member
Joined
Aug 14, 2006
Messages
22
Reaction score
0
Your Mercedes
W221, W211, W202
  • Thread Starter
  • Thread starter
  • #20
Hi,
Sorry to jump in but I've got the same car with some faults that some of you guys are helping me with but I too have the Radio/RWH interferrence problem. The N10 Relay was mentioned, could someone please tell me where this lives.:Oops:

Malcolm should know
 


Specialist Car Insurance provider in the UK offering cheap car insurance quotes for all risks including Mercedes cars.
Top Bottom