w202 heat/vent issue

pinkaroo

New Member
Joined
Nov 15, 2009
Messages
4
Reaction score
0
I have a W202 C250 TD registered in 1999. It has started allowing hot air to be emitted from the windscreen vent and selecting the lower vents on the climate control and setting the fan to a higher speed setting just causes hot air to be emitted faster from the upper windscreen vent and nothing comes out of the lower vents. Is it the old duovalve again I need to check for 12v pulses or something else? I have noticed turning off the climate control does not elicit the usual sound of a valve closing? Thoughts and ideas greatly received. Two recent events which may have contirbuted are a main dealer B service and me taking the wiper assembly off to fix the old juddering wiper/reset the park position. Have I disturbed a vacuum pipe?
 
OP
P

pinkaroo

New Member
Joined
Nov 15, 2009
Messages
4
Reaction score
0
  • Thread Starter
  • Thread starter
  • #3
Thanks Malcolm, Is that assembly under the dash where the pollen filter is housed?
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
367
Age
89
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Thanks Malcolm, Is that assembly under the dash where the pollen filter is housed?

Yes that is all under the dash,,you may hear a hissing sound under there if a pipe is off
 

You lost your key ? Or maybe you need a spare! Your vehicle imobilliser does not respond anymore? WE CAN FIX THEM ALL !! Mobile ! Save Time and Increase Profits With us !
Top Bottom