1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

W202 Heater Problem

Discussion in 'Electrics, Vacuum, Ignition and ECU' started by Andyi, Nov 14, 2012.

  1. Andyi

    Andyi Member

    Messages:
    15
    Likes Received:
    0
    Joined:
    Jan 7, 2012
    Location:
    London
    Your Mercedes:
    C180 Sport W202
    I done a service on my mates dads W202 P reg over the weekend.

    I changed the cabin filter as there was bearly any air being blowen into the car from the heaters. Must have never been changed

    However, the heaters blow out hot air when the car is moving but as you come to a stop they blow out cold air, without touching any switches so they are still set to hot.

    It was doing the same thing before i changed the cabin filter.

    Anyone experienced anything like this before?
     
  2. television

    television Always remembered RIP

    Messages:
    164,074
    Likes Received:
    310
    Joined:
    Mar 14, 2005
    Location:
    Daventry
    Your Mercedes:
    2002 SL500, 216 CL500, all fully loaded
    I would think the the water circulation pump has packed up, its 150 in the picture

    [​IMG]
     
  3. OP
    Andyi

    Andyi Member

    Messages:
    15
    Likes Received:
    0
    Joined:
    Jan 7, 2012
    Location:
    London
    Your Mercedes:
    C180 Sport W202
    I have found this on my W reg W202 just under the air box but i cant find it on the P reg.
    Do you know where it is?
    Its got aircon just like mine has
     
  4. television

    television Always remembered RIP

    Messages:
    164,074
    Likes Received:
    310
    Joined:
    Mar 14, 2005
    Location:
    Daventry
    Your Mercedes:
    2002 SL500, 216 CL500, all fully loaded
    If you follow the pipe back from the duovalve you will come to it
     

Share This Page