1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

W204 2009 limp mode. EGR OR INJECTOR... Let's see.

Discussion in 'Electrics, Vacuum, Ignition and ECU' started by Darren Porter, Sep 11, 2019.

  1. Darren Porter

    Darren Porter New Member

    Messages:
    8
    Likes Received:
    2
    Joined:
    Sep 9, 2019
    Your Mercedes:
    C200 CDI 136bhp 2009 w204
    My w204 is kicking into limp mode at various points, usually when trying to build speed or uphill.
    The gearbox kickdown is slow and sluggish.
    The engine light shows egr issues, and an injector with issues. After clearing a few times the injector persists and the egr hit and miss.
    Also, the engine fan is full blast from turn over and never stops.
    I'm guessing this is an AC sensor after reading some forums.. Ill put that on also, give it new filters and oil and see if really need new injectors... I hope not :(

    Getting new egr in next few days, will try it let you know if it improves.
     
  2. Blobcat

    Blobcat Moderator

    Messages:
    15,617
    Likes Received:
    3,907
    Joined:
    Feb 8, 2006
    Location:
    Near Grange Moor (not Wakefield...)
    Your Mercedes:
    R171 SLK280 3.0, Land Rover 110 County SW
    Hello and welcome

    Have you had the codes read by a Mercedes specific code reader?
     
  3. mersum1es

    mersum1es Senior Member

    Messages:
    1,703
    Likes Received:
    107
    Joined:
    Sep 25, 2010
    Location:
    Finland
    Your Mercedes:
    W219/-07/320CDI, W220/-01/320CDI, EX:W211/-04/320CDI, EX:W210/-01/270CDI
    check all fuses (full blast fan may indicate blown ecu fuse too)

    if there are delphi injectors, they are really PITA ones...
     
  4. OP
    Darren Porter

    Darren Porter New Member

    Messages:
    8
    Likes Received:
    2
    Joined:
    Sep 9, 2019
    Your Mercedes:
    C200 CDI 136bhp 2009 w204
    I've had it done at a few places but not Mercedes just yet. EGR emission ertod and an injector reading too.
    I'll replace the egr, but the lack of power I think it's deeper.
    Il. Update you when I get to Mercedes and also when I get the injectors tested :)
     
  5. OP
    Darren Porter

    Darren Porter New Member

    Messages:
    8
    Likes Received:
    2
    Joined:
    Sep 9, 2019
    Your Mercedes:
    C200 CDI 136bhp 2009 w204
    Good idea.
    Ivr checked all the fuses under bonnet, still need to do the few in the back but all coming back OK.

    But! When I was fiddling about with testing, a 20amp fuse popped that was for the staring motor relay. So maybe a short somewhere... Would this affect the engine codes and the lack of power?
     

Share This Page