W211 (54) 320cdi Instrument Display Leds.

rob hamill

Senior Member
Joined
Oct 8, 2005
Messages
66
Reaction score
0
Location
glasgow
I would just like to share this with all you w211 guys who have not encountered this problem as yet. Leds have gone out in the cluster, merc want £780+vat+labour. Also not a lot of ways out as Recons are just as expensive with still the same hassle getting it all corrected at your dealer in the end. I stripped the cluster down to inspect but the small white leds are on the PCB. I put it all together again, started it up and all was ok except the leds. I was hoping the disconnection then reconnection would have solved the problem. When i stripped it down they were all removable parts so i thought that if i got another cluster from salvage i could change the led section or could anyone tell me which part has the main membrane thus put that part in the salvaged cluster to save a whole lot of hassle of mileage correction etc,etc!. Could be a bright idea. Any help would be nice.

Kind regards.
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Hello Rob,,,LEDs do not give much problem. they would be 3.6 volt each and that would mean 4 in series in any circuit I would have said that this was just a poor connection on the Leds somewhere,,I will see what is shown for the cluster in the morning
 
OP
rob hamill

rob hamill

Senior Member
Joined
Oct 8, 2005
Messages
66
Reaction score
0
Location
glasgow
  • Thread Starter
  • Thread starter
  • #3
Thanks Malcolm...any help would be much appreciated. These are the times i wish i still had my W210 when you just popped into merc and got a couple of bulbs. Thanks Robert.
 

jberks

Senior Member
Joined
May 12, 2004
Messages
11,145
Reaction score
23
Location
M1, Outside lane, somewhere between Leeds and Lond
Your Mercedes
Jaguar XF 3.0 S, LR Freelander 2, Fiat 500 & Fiat Panda
I didn't think the dash was LED lit.
I thought it was a cold cathode arrangement. The way it lights doesn't point to LED, it seemed too slow for that with a flourescent type 'flicker' style start up like cold cathodes do, plus, can you dim LEDS?
Can't help with a fix I'm afraid. I was lucky, mine was replaced under warranty when the tacho stopped illuminating.
 
OP
rob hamill

rob hamill

Senior Member
Joined
Oct 8, 2005
Messages
66
Reaction score
0
Location
glasgow
  • Thread Starter
  • Thread starter
  • #5
Thanks

Thanks jBerks...Dimmer works fine and dims the needles, fuel, temp and the main round screen but not getting the actual back lights which you described very well. It is just a pain in the arse and the dark!... It is a pity as the car is a late 54 (Nov) with 92k and a full MB service history. Do you think it is worthwhile buying the one thats on ebay for £100 which is the same part number and all working as stated. My only prob is that they dont know the mileage. Can i get this corrected to my current mileage of 92k at the dealer ?. I dont mind spending a couple of hundred to get it up and running again but not a grand as quoted. Much appreciated.
 

jberks

Senior Member
Joined
May 12, 2004
Messages
11,145
Reaction score
23
Location
M1, Outside lane, somewhere between Leeds and Lond
Your Mercedes
Jaguar XF 3.0 S, LR Freelander 2, Fiat 500 & Fiat Panda
I agree, very annoying if it doesn't light up and it would certainly spoil my enjoyment of the car, having such an unrepairable fault. I did wonder what would happen as the cars age, without replaceable bulbs and having had mine go when it was less than 3, this will become an increasingly frequent issue I suspect.

I haven't seen the ebay one but provided its the same part number and in perfect working order I would go for it.
Recoding will be a star job but shouldn't be expensive at an indie and overall a lot cheaper than a new cluster.
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
You can dim LEDs to a point just by the voltage input
 

jberks

Senior Member
Joined
May 12, 2004
Messages
11,145
Reaction score
23
Location
M1, Outside lane, somewhere between Leeds and Lond
Your Mercedes
Jaguar XF 3.0 S, LR Freelander 2, Fiat 500 & Fiat Panda
Maybe if Rob gets the replacement he could let you have a look at the old one to see whats involved in fixing it. I suspect this is the first of many so it would be nice to know if there is a simple fix available as an alternative to Merc's £1000.
 
OP
rob hamill

rob hamill

Senior Member
Joined
Oct 8, 2005
Messages
66
Reaction score
0
Location
glasgow
  • Thread Starter
  • Thread starter
  • #9
Many thanks guys! This is all very much appreciated. I am gonna go with the ebay option then a recode. Once I am up and running I will be more than happy to send Television the cluster free of charge to keep for his experimental laboratory disection in a quest to maybe get a result that will help others, and who knows this might be the thread of the future.
 

You lost your key ? Or maybe you need a spare! Your vehicle imobilliser does not respond anymore? WE CAN FIX THEM ALL !! Mobile ! Save Time and Increase Profits With us !
Top Bottom