W211 E270 cdi 2003 Cd stuck (wont eject)

chookdoo27

Active Member
Joined
Feb 22, 2009
Messages
38
Reaction score
0
I have tried to eject a cd from the cd unit but it doesnt seem to do a thing apart from telling me to remove the disc.

Lately its been skipping tracks a lot and now it wont play the cd either.

Radio works fine

I dont know what model it is but its a standard single cd unit in a 03 e270 cdi avantgarde.

Can you suggest what i could do please!
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
331
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Is this built into the Comand
 
OP
C

chookdoo27

Active Member
Joined
Feb 22, 2009
Messages
38
Reaction score
0
  • Thread Starter
  • Thread starter
  • #3
Yes it is, i dont know which model it is, it keeps happening then if i leave it off a while or turn the engine off then it spits it out after pressing it a few times but it does come up with please remove disc but obviously doesnt eject it.

I had it happen yesterday and it kept telling me my sat nav disc was defective, a bit later it ejected and sat nav was all ok.

Another thing ive noticed is when its all ok when i have the stereo turned off i can still hear the cd spinning constantly.

Thanks
 
OP
C

chookdoo27

Active Member
Joined
Feb 22, 2009
Messages
38
Reaction score
0
  • Thread Starter
  • Thread starter
  • #4
Its a aps 50 and ive still got problems it now wont eject at all and its still telling me the sat nav disc is defective which it isnt whe its working all ok.

Ideas needed as i dont really want to lay out for a new unit.

Thanks
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
331
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Have you asked Becker if they will fix it
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
331
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
A 2003 car could have a Bosch version.

People on Ebay offer a repair service for this fault
 
OP
C

chookdoo27

Active Member
Joined
Feb 22, 2009
Messages
38
Reaction score
0
  • Thread Starter
  • Thread starter
  • #8
Ive taken it into a local car Audio shop, theyve taken it out and have sent it off.

I shall update when returned with a fault and price
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
331
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
I think it is a firm called maple audio that repairs them
 
Top Bottom