W220 A/C blowers eratic

davidslater

Member
Joined
Jul 15, 2013
Messages
15
Reaction score
0
Location
England
Your Mercedes
W220
Car: S500 5.0 302BHP
Year: 2004

Noticed last week blowers seemed to have developed a mind of their own!

Turn blower onto A/C or heat and they will come on and run for around 10 seconds. They will turn off very slowly as if I was turning them down.

They will then turn back on randomly and run for another few seconds (anywhere between 3-15 seconds) then slowly turn back off. They might stay off for 1 mintue or 30 minutes before turning back on.

The A/C blows icy cold air when it does come on. So I presume that side of things is fine.

I have tried the following -

1. aircon regassed.
2. Checked A/C for leaks
3. read instruction manual (well, you never know!)
4. Turned off 'Auto' settings
5. Turned on 'Auto' settings.

Nothing seems to work.

Thoughts?
 
Last edited:

whitenemesis

Senior Member
Joined
Dec 21, 2006
Messages
17,978
Reaction score
32
Your Mercedes
CLS55 AMG '05
You say there is no difference in the blower operation irrespective of having the Auto on or off? I'd expect the blower to remain at whatever setting you have selected when Auto is off but it should slowly adjust up and down as cabin temp changes when Auto is on.
 
OP
D

davidslater

Member
Joined
Jul 15, 2013
Messages
15
Reaction score
0
Location
England
Your Mercedes
W220
  • Thread Starter
  • Thread starter
  • #3
I dont think I explained properly.

1. If I manually set blower speed at level 1 (lowest settings) it will run at level 1 for a few seconds then turn off. If I set it at level 5 (highest setting) It will run for a few seconds then turn off.

2. If I use 'Auto' setting, again it will run for a few seconds then turn off.

In both cases it will randomly come back on run for a few seconds then turn off.

It wont get the temp to the desired setting (whether hot or cold)

It does blow hot or cold air (whichever is set)
The blower does blow
The A/C gas was done and is OK
The A/C was checked for leaks and its OK

I've owned the car for a few years and its never done anything like this.
 
Last edited:

whitenemesis

Senior Member
Joined
Dec 21, 2006
Messages
17,978
Reaction score
32
Your Mercedes
CLS55 AMG '05
STAR diagnosis would probably be a good starting point but it does sound like the blower regulator pack has or is about to fail.
 
OP
D

davidslater

Member
Joined
Jul 15, 2013
Messages
15
Reaction score
0
Location
England
Your Mercedes
W220
  • Thread Starter
  • Thread starter
  • #5
Ouch! just phoned main dealer and they want nearly £300

Have you got a part number? I'm thinking maybe try ebay for a part.
 

whitenemesis

Senior Member
Joined
Dec 21, 2006
Messages
17,978
Reaction score
32
Your Mercedes
CLS55 AMG '05
A2208210951 £170.04 from MB

Check the part number before purchase.

Always best to get the fault codes read first though
 
Last edited:

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
341
Age
87
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Do turn the auto air con off and try the blower and see if it will keep running, set it to hot if need be, and see if the fan will run uninfluenced from the auto setting.

It could be the reg pack and if it is you can buy much cheaper than from Mercedes, Ebay for a start or ECP. It is under the dash and the motor usually has to be dropped.
 
OP
D

davidslater

Member
Joined
Jul 15, 2013
Messages
15
Reaction score
0
Location
England
Your Mercedes
W220
  • Thread Starter
  • Thread starter
  • #9
Do turn the auto air con off and try the blower and see if it will keep running, set it to hot if need be, and see if the fan will run uninfluenced from the auto setting.

It could be the reg pack and if it is you can buy much cheaper than from Mercedes, Ebay for a start or ECP. It is under the dash and the motor usually has to be dropped.

I've tried with heat up full and adjusting fan speeds in 'Auto' and 'Manual' modes with A/C off and it does exactly the same thing - blows for a few seconds then turns off then comes back on randomly while driving.

Is this the part I need? -http://www.ebay.co.uk/itm/Heater-Blower-Resistor-MERCEDES-C-CLK-E-G-S-SL-SLK-2208210951-/261090953566?pt=UK_CarsParts_Vehicles_CarParts_SM&hash=item3cca3bc95e

Maybe the dealer thought I wanted the whole unit including blower?
 

whitenemesis

Senior Member
Joined
Dec 21, 2006
Messages
17,978
Reaction score
32
Your Mercedes
CLS55 AMG '05
Seems to be the correct part number and a good price! Always good to have the dealer price as a benchmark though as some ebay "bargains" are anything but!!


The blower itself is £423 from MB ...
 
Last edited:

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
341
Age
87
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
I've tried with heat up full and adjusting fan speeds in 'Auto' and 'Manual' modes with A/C off and it does exactly the same thing - blows for a few seconds then turns off then comes back on randomly while driving.

Is this the part I need? -http://www.ebay.co.uk/itm/Heater-Blower-Resistor-MERCEDES-C-CLK-E-G-S-SL-SLK-2208210951-/261090953566?pt=UK_CarsParts_Vehicles_CarParts_SM&hash=item3cca3bc95e

Maybe the dealer thought I wanted the whole unit including blower?

Yes that is the part :D:D I do not think it is the motor brushes as it would not be that constant.

If you would like the fitting instructions then I can send them to you.

Mercedes do charge some stupid amounts for these things.
If you had a voltmeter you could measure the input to the reg pack where it should be 0 to 5 volt depending on the output setting
 

whitenemesis

Senior Member
Joined
Dec 21, 2006
Messages
17,978
Reaction score
32
Your Mercedes
CLS55 AMG '05
You might find this video helpful, if you wish to DIY

[YOUTUBE]93AuDb9Yoik[/YOUTUBE]
 
OP
D

davidslater

Member
Joined
Jul 15, 2013
Messages
15
Reaction score
0
Location
England
Your Mercedes
W220
  • Thread Starter
  • Thread starter
  • #13
Thats a great video. I'm going to order the part and give it a go.

Cheers guys!
 
OP
D

davidslater

Member
Joined
Jul 15, 2013
Messages
15
Reaction score
0
Location
England
Your Mercedes
W220
  • Thread Starter
  • Thread starter
  • #14
I'm thinking I may as well change the filters while I have the covers off.

1. Whart are the part numbers for Charcoal filters (near blower fan assembly)
2. What are part numbers for filters in glove box

Thanks guys
 
OP
D

davidslater

Member
Joined
Jul 15, 2013
Messages
15
Reaction score
0
Location
England
Your Mercedes
W220
  • Thread Starter
  • Thread starter
  • #16
Got both sets of Mann Hummel filters for £60+VAT from Andrew Page (after a bit of haggling!)

Hopefully regulator will be here tomorrow and I'll be able to let you know how it goes

Fingers crossed!
 
OP
D

davidslater

Member
Joined
Jul 15, 2013
Messages
15
Reaction score
0
Location
England
Your Mercedes
W220
  • Thread Starter
  • Thread starter
  • #17
Just a quick update -

I changed the regulator and filters. The fans and air con are working perfectly!

Thanks for all the help guys.
 
Top Bottom