wiper problem

clelly

Senior Member
Joined
Jan 10, 2007
Messages
137
Reaction score
0
Hi,I hope I am posting in the correct section.Wipers I hope come under the electrics heading. I have a year 2000 (w202) C 200 elegance petrol. My wiper is coming to rest around 6 inches above the bottom of my windscreen (angle approx 33 degrees.) It is only doing this as it comes to a halt. If I have the wipers on full they work no problem with no sticking, however if I switch them off they will stop in the afforementioned position. Does this point to an obvious fault. I spoke to eurocars today and they have 3 seperate sections that make up the wiper mechanism. I assume it is not the motor as the wiper motion is smooth. Also I have lubricated both of the piston sections at the base of the wiper. Thanks
 

Alex Crow

Senior Member
Joined
Jul 9, 2009
Messages
10,677
Reaction score
40
Location
Super Suffolk
Your Mercedes
W169, W124, w202, W203, KTM 250 EXC, VW T25 camper and a Polo in a pear tree
a common problem. the nut has come loose enough to allow the arm on the motor to turn slightly.

no new parts are needed. just remove the mechanism and realign the arm at the motor end of the mech, then tighten the nut nice and tight. easy for an experienced and intelligent diy.
 
OP
C

clelly

Senior Member
Joined
Jan 10, 2007
Messages
137
Reaction score
0
  • Thread Starter
  • Thread starter
  • #3
Hi Alexander thanks for your reply. This is probably a silly question but could you tell me where this nut is?
Thanks
 

Alex Crow

Senior Member
Joined
Jul 9, 2009
Messages
10,677
Reaction score
40
Location
Super Suffolk
Your Mercedes
W169, W124, w202, W203, KTM 250 EXC, VW T25 camper and a Polo in a pear tree
you will have to remove the wiper mechanism complete.

i could try to talk you through it, but it would be a long post and i have no idea of your competency level (no offence!!). so it may be best all round if you purchase a haynes manual to guide you through it.

good luck!
 

Dec

Senior Member
Joined
Nov 30, 2005
Messages
3,300
Reaction score
3
Location
Ireland.
Your Mercedes
W202
As Alexander says you have the same problem as in post #45 here, you will need to reset the park position of the MOTOR then remove and reset the park position of the MECHINASIM by adjusting nut 1 and/or nut 2

See also… Mechinasim Removal

Dec
 

Alex Crow

Senior Member
Joined
Jul 9, 2009
Messages
10,677
Reaction score
40
Location
Super Suffolk
Your Mercedes
W169, W124, w202, W203, KTM 250 EXC, VW T25 camper and a Polo in a pear tree
well done dec!! top links my friend.
 

Avantgarde Automotive, Mercedes-Benz and SLR McLaren specialists. Service, repairs, diagnosis and motorsport preparation.
Unit 14 Hither Green Trading Estate, Clevedon, Somerset, BS21 6XU Tel: 01275 217270 Email:steve@avantgarde-automotive.co.uk
www.avantgarde-automotive.co.uk
Top Bottom