124 eclass sportline ecu problem?

g60keith

New Registration
Joined
Jul 5, 2009
Messages
1
Reaction score
0
Hi there i was wondering if theres any technical people out there who know there stuff about electrical problems,my 320 eclass was running but not idling and then i had a little fire on the air mass loom, i have replaced the air mass and wiring looom to the affected area only but have no spark anymore to plugs,Question being have i ruined the ecu?and can it be tested /checkedsome how before replacing? i would appreciate any professional adviceregarding this sportline as i love the wagon
 

124coupe

Senior Member
Joined
May 7, 2006
Messages
532
Reaction score
2
I suspect your whole loom is gone. Did all this start after maintenance work (e.g. changing the plugs)?

The ECU<->coil wires can short out if the insulation has broken down and the ECU output stage(s) can be blown. Repair is possible by sending the ECU away but pointless if the loom is bad.
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
367
Age
89
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Yes I suspect that an ECU is damaged, there are firms that repair and test them, I take it that the car is about 1993 in build
 

Avantgarde Automotive, Mercedes-Benz and SLR McLaren specialists. Service, repairs, diagnosis and motorsport preparation.
Unit 14 Hither Green Trading Estate, Clevedon, Somerset, BS21 6XU Tel: 01275 217270 Email:steve@avantgarde-automotive.co.uk
www.avantgarde-automotive.co.uk
Top Bottom