1993 R129 300sl no start

Fleetwood

Senior Member
Joined
Jun 20, 2012
Messages
163
Reaction score
0
Location
Horsham, West Sussex
Your Mercedes
2005. SL350
hi all
Haven’t been on here in a while as the merc (R230)has been running well

BUT ! I now have a R129 300SL that I’ve just acquired that won’t start, battery is good and well charged, turn the key and all lights on the dash light up but won’t crank over, if I jump the starter motor it fires up

Any ideas on what else it could be ?
 

LostKiwi

Senior Member
Joined
Aug 25, 2006
Messages
26,444
Reaction score
15,896
Location
Midlands / Charente-Maritime
Your Mercedes
'93 500SL-32, '01 W210 Estate E240, 02 R230 SL500 (Malcolm Spec), 04 Smart Roadster Coupe
You may have a bad neutral safety switch. Its located on the side of the gearbox and reports to the ecu which gear is selected. To diagnose it easily requires STAR
 
OP
Fleetwood

Fleetwood

Senior Member
Joined
Jun 20, 2012
Messages
163
Reaction score
0
Location
Horsham, West Sussex
Your Mercedes
2005. SL350
  • Thread Starter
  • Thread starter
  • #3
Just changed that for a new one, also have changed the ignition just in case
 

LostKiwi

Senior Member
Joined
Aug 25, 2006
Messages
26,444
Reaction score
15,896
Location
Midlands / Charente-Maritime
Your Mercedes
'93 500SL-32, '01 W210 Estate E240, 02 R230 SL500 (Malcolm Spec), 04 Smart Roadster Coupe
Also it’s a 1993 so star wont work on this old girl
Yes it will.
Works fine on my 93 500SL.

It may also be a bad starter solenoid.
When you turn the key is there a click?
 
OP
Fleetwood

Fleetwood

Senior Member
Joined
Jun 20, 2012
Messages
163
Reaction score
0
Location
Horsham, West Sussex
Your Mercedes
2005. SL350
  • Thread Starter
  • Thread starter
  • #6
Nope nothing, if I jump the starter she fires up fine so can’t be the starter, no power on the small wire to the solenoid

Thinking it could be the starter relay K38 but don’t know where it is
 

LostKiwi

Senior Member
Joined
Aug 25, 2006
Messages
26,444
Reaction score
15,896
Location
Midlands / Charente-Maritime
Your Mercedes
'93 500SL-32, '01 W210 Estate E240, 02 R230 SL500 (Malcolm Spec), 04 Smart Roadster Coupe
I don't think they had a k38 relay at this age.

From what I recall the power to the solenoid goes from ignition switch to neutral safety to solenoid.
 

LostKiwi

Senior Member
Joined
Aug 25, 2006
Messages
26,444
Reaction score
15,896
Location
Midlands / Charente-Maritime
Your Mercedes
'93 500SL-32, '01 W210 Estate E240, 02 R230 SL500 (Malcolm Spec), 04 Smart Roadster Coupe
Put 12v on the solenoid to check that works as well.
 
OP
Fleetwood

Fleetwood

Senior Member
Joined
Jun 20, 2012
Messages
163
Reaction score
0
Location
Horsham, West Sussex
Your Mercedes
2005. SL350
  • Thread Starter
  • Thread starter
  • #11
If I put power to the solenoid she starts straight up, but don’t have power to the safety switch
 
OP
Fleetwood

Fleetwood

Senior Member
Joined
Jun 20, 2012
Messages
163
Reaction score
0
Location
Horsham, West Sussex
Your Mercedes
2005. SL350
  • Thread Starter
  • Thread starter
  • #13
Do you know what wires go where by any chance . Got the cable off the ignition switch and power on 2of them
 

LostKiwi

Senior Member
Joined
Aug 25, 2006
Messages
26,444
Reaction score
15,896
Location
Midlands / Charente-Maritime
Your Mercedes
'93 500SL-32, '01 W210 Estate E240, 02 R230 SL500 (Malcolm Spec), 04 Smart Roadster Coupe
Power will only be present on the solenoid connection when the key is turned. It should be easy to identify by connecting a meter to each connection in turn, turning the key and looking for the one that becomes live when the key is in the crank position.
 
OP
Fleetwood

Fleetwood

Senior Member
Joined
Jun 20, 2012
Messages
163
Reaction score
0
Location
Horsham, West Sussex
Your Mercedes
2005. SL350
  • Thread Starter
  • Thread starter
  • #15
Ok the girlfriend use turned up so have managed to work out what wire is the starter, ignition switch is working fine, but even when put 12v to the starter wire from the ignition she still won’t crank
 

LostKiwi

Senior Member
Joined
Aug 25, 2006
Messages
26,444
Reaction score
15,896
Location
Midlands / Charente-Maritime
Your Mercedes
'93 500SL-32, '01 W210 Estate E240, 02 R230 SL500 (Malcolm Spec), 04 Smart Roadster Coupe
Ok the girlfriend use turned up so have managed to work out what wire is the starter, ignition switch is working fine, but even when put 12v to the starter wire from the ignition she still won’t crank
Ok so do the same check at the neutral safety then 'just' trace the wiring
 
OP
Fleetwood

Fleetwood

Senior Member
Joined
Jun 20, 2012
Messages
163
Reaction score
0
Location
Horsham, West Sussex
Your Mercedes
2005. SL350
  • Thread Starter
  • Thread starter
  • #17
Lol trace the wiring you know how theses cars are built, ok so weekend job is interior out
 

LostKiwi

Senior Member
Joined
Aug 25, 2006
Messages
26,444
Reaction score
15,896
Location
Midlands / Charente-Maritime
Your Mercedes
'93 500SL-32, '01 W210 Estate E240, 02 R230 SL500 (Malcolm Spec), 04 Smart Roadster Coupe
Lol trace the wiring you know how theses cars are built, ok so weekend job is interior out
Thats why the just was in quotes! :)

I'll see if I can find a wiring diagram if I get the chance.
 
OP
Fleetwood

Fleetwood

Senior Member
Joined
Jun 20, 2012
Messages
163
Reaction score
0
Location
Horsham, West Sussex
Your Mercedes
2005. SL350
  • Thread Starter
  • Thread starter
  • #20
Lostkiwi any luck with that wiring diagram? Have double checked everything - power from ignition switch, no power to the neutral safety switch, if I put power down the safety switch she will start right up

So it’s either a relay somewhere or a broken wire, the cable at the neutral safety switch isn’t the same colour from the ignition switch
 

You lost your key ? Or maybe you need a spare! Your vehicle imobilliser does not respond anymore? WE CAN FIX THEM ALL !! Mobile ! Save Time and Increase Profits With us !
Top Bottom