2003 Sl55 AMG transmission slack & squeak??

NickH72

New Member
Joined
May 29, 2009
Messages
3
Reaction score
0
Hi all,

Not sure if thats the best description so i will explain.

I have a late 2003 SL55 amg with 35k miles

When i pull away there seems to be some "take up" in the drivetrain after the initial pull away and i can hear a squeak when it does fully take up.

If i pull up slowly then pull away slowly it doesnt do it.. if i hit the brakes then the throttle it is quite obvious in a little delay or jolt and a squeek.

Any ideas? to me there is some play somewhere or something is shifting back and forward on a mounting..

Appreciate your thoughts as its really getting annoying!

Thanks

Nick
 
OP
N

NickH72

New Member
Joined
May 29, 2009
Messages
3
Reaction score
0
  • Thread Starter
  • Thread starter
  • #2
Although convinced its a transmission squeak i have just read a thread about the supercharger belt squeaking in a similar way.. so still open to suggestions but maybe i am looking in the wrong place? does seem to feel like "taking up the slack though"

Thanks
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
331
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Hello and welcome, I run a 230 500SL and what you describes seem to me a drive train fault, thought its hard to think of what it could be, there is nothing known,,I would get an indie to check the prop shaft and axle drive shafts.
 


Prestige Motor Group is Hertfordshire's Premier INDEPENDENT MERCEDES BENZ SPECIALIST. We offer a service exceeding Main dealership expectations and HUGE savings on Main Dealership Prices. WE BEAT ANY GENUINE QUOTE! Prestige Motor Group pride ourselves on delivering excellent customer service as we believe the customer and the Car deserve the best.
Tel: 01462 672458www.prestigemotorsofhertfordshire.co.uk/
Top Bottom