230k cutting out

manny

Member
Joined
Sep 13, 2009
Messages
17
Reaction score
0
hi all fault started 2day when pulling up car cuts out. it restart first turn of the key it is an auto if it was manual i would say it my driving. i have had it pluged as i am of work this week and there is no faults only seems fault as pulling up it has happen 15-20 times and doing my tree in any help with what it could be please
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
The MAF can be responsible for this,,try it unplugged, I cannot guarantee that it will run like it , but some will
 
OP
M

manny

Member
Joined
Sep 13, 2009
Messages
17
Reaction score
0
  • Thread Starter
  • Thread starter
  • #3
i put a new maf on monday 130pound as i had a p0170 but now it has cleared and there are no fault at 5 tonite
 
OP
M

manny

Member
Joined
Sep 13, 2009
Messages
17
Reaction score
0
  • Thread Starter
  • Thread starter
  • #5
its a c class 230 komp auto
 

E300tdHighlander

Senior Member
Joined
Feb 22, 2009
Messages
47
Reaction score
0
Age
38
Location
Highlands Scotland
Your Mercedes
W210 300td estate.
Maybe gummed up throttle body or idle control valve(not sure if relevant for your car)

Sure someone with more knowledge on mercedes will be along to help you in a while.
 
OP
M

manny

Member
Joined
Sep 13, 2009
Messages
17
Reaction score
0
  • Thread Starter
  • Thread starter
  • #7
thanks for the help i will go have a look and clean them if i can remove them. i hope i get it fix as got a 4 hour drive tomor in it:confused:
 

Alex Crow

Senior Member
Joined
Jul 9, 2009
Messages
10,677
Reaction score
40
Location
Super Suffolk
Your Mercedes
W169, W124, w202, W203, KTM 250 EXC, VW T25 camper and a Polo in a pear tree
could be a sticking purge valve. it is on your n/s inner wing at the end of an 8mm black plastic pipe. it has MOT written on top too. disconnect the engine side pipe from it and blank off the end of this pipe. now drive it again...
 
OP
M

manny

Member
Joined
Sep 13, 2009
Messages
17
Reaction score
0
  • Thread Starter
  • Thread starter
  • #9
thanks for all the help got put my hands up when i fitted the maf sensor put the wiring the wrong side and rubbed on alt belt and was earthing out on a pully thanks for all the help
 


As a member of ourMercedes Owners' club, you will enjoy numerous savings on an expanding range of services including, Insurance, Parts and Servicing, RAC Membership plus much more.MBOmembers can save around £200.00 a year. You can join from as little as £30.00 and start to enjoy these savings immediately. You receive our monthly magazine and free classified ads when you decide to trade up a model.
Top Bottom