300SL Wiper Problem

R

Raz53

Guest
Hi guys, I own a '91 300SL and have a wiper problem. It only occurs when I turn the wipers on "intermittent". They work irregularly, and after a few "swipes", they stop. Even when irregular, it stops at random locations across the windshield. I can push the switch and get it to move and eventually get it back to its "parked" position. Oh, if turned on to wipe in the regular mode, it works perfectly.

Any ideas?

Raz
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
331
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Hello and welcome, a good dose of switch cleaner should sort that out in the switch
 
OP
R

Raz53

Guest
  • Thread Starter
  • Thread starter
  • #4
When I said "switch" I'm referring to the steering column mounted stalk control.
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
331
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
When I said "switch" I'm referring to the steering column mounted stalk control.

Thats the one that needs to be cleaned, it should solve the fault
 

We are a completely independent Mercedes Benz service, Mercedes repair and Mercedes MOT centre located in Warrington, Cheshire and have been established since April 2006. All servicing carried out by MB Tech is in accordance with manufacturer service schedules and carried out by Mercedes Benz trained mechanics.
Contact MB-TECH on 01925 653050 or visitwww.mercedesservicingwarrington.co.uk
Top Bottom