300td loosing power and squeeling

ben creighton

New Member
Joined
Jul 24, 2009
Messages
2
Reaction score
0
Hi all, new to the board - this is my first post.

My 300td elegance (1998) has lost its power when accelerating. Not only that, it squeels - same noise as when your fan belt goes - when you accelerate hard.

Is this a job for a qualified mechanic?

Thanx

ben
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
331
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Hello and welcome:D:D The squealing will be from the serpentine belt on the front of the engine,,this also drives the turbo,, this could be just the belt,,or the turbo could have seized. slipping of the belt and turning the turbo by hand would answer it all
 

luders79

Senior Member
Joined
Jun 13, 2006
Messages
193
Reaction score
0
Location
London
Your Mercedes
W210 estate
thought all turbos were driven by exhaust gases ! Kompressors/supercharges are belt driven! back to the orginal post it could also by gearbox related! had a couple of 210's with similar faults !
 

rpe2

Senior Member
Joined
Sep 25, 2006
Messages
2,863
Reaction score
2
Age
43
Location
Silchester
Your Mercedes
His: 2018 E220 d; Hers: 2016 SMAX
They are.

2 possibly seperate faults here.

Drive belt may be worn.

Loss of power. Is there a hiss/ woosh noise under hard acceleration. If so may be a split turbo pipe/ intercooler.

Where are you located Ben, and welcome?
 

simon_wall69

Senior Member
Joined
Oct 9, 2007
Messages
502
Reaction score
1
Location
Stone, Staffordshire
I would assume the belt has come off and taken a hose out of the intercooler or turbo - might only be a matter of re-attaching and replacing belt and tensioner.
 

Comand Online Ltd is a specialist supplier of Mercedes Navigation Disks, Phone & Bluetooth, iPod, DAB, CD and other COMAND retrofit parts to enhance your vehicle.www.comandonline.co.uk
Top Bottom