500sl w129 1990 electrical and engine problems

tiggins

New Member
Joined
Jun 21, 2009
Messages
9
Reaction score
0
hi all. please read this i have got several problems on my car if i list them all it may just jog someones memory and they may all be conected if not then any help with any of them will be much apreciated. HERE GOES. i have a 500sl. 1990 on a H reg. w129. i have had several problems recently all electrical. first of all was a power drain on the battery. eventualy disconecting the electric ariel seems to have stopped this.
the abs and asr lights have been on since i first got the car two years ago. if i start the car they go out. 99 times out of 100 as soon as i start to drive off they come on both together everytime. on the very odd occasion they do not come on then when i am slowing down almost stopped you actualy feel the abs kick in and the pedal vibrates. but this does not happen if the lights are lit.
just before christmas the soft top started to act daft on the button. not opening properly or closing every time it gets to a certain stage and stops until i manualy hold up the hideaway compartment lid then it carries on working.
then just over the last couple of weeks the engine is giving me trouble, it started off with one day whilst driving not realising the engine must have cut out and then bump started itself with one hell of a backfire. then a day or two later the same happened only this time i knew it had cut out only before i had chance to do anything again it started itself again with a backfire. the last time it has done it the power loss was for more than a few seconds giving me chance to stop. it started straight away but was coughing and spluttering, no power, missfiring and a real pain to try to drive then as quick as it started it coughed and started to run fine again.
i have had it to a mercedes van mechanic who has tried to check it out. he has tried it on his machine only he beleives because of the year it uses the blink code system. unfortunatly he is used to the more modern mercedes and has to admit defeat with this. but if this helps he did say that ocasionaly he could get a blink code of 12 from the car but his list goes from 1 to 10 then 14 onwards. he is only guessing but seems to think it could be the ecu that has gone down. helppppppppppppp ppppplease!!!! is there anyone out there who can shed light on this or anyone who is prepared to have a look at it and sort it. this is the wifes car, her dream car that she always wanted. she doesnt have pots full of cash so a back handed payment would be best thanks tig!!!
 

bigasotonuk

Senior Member
Joined
Nov 14, 2006
Messages
5,315
Reaction score
43
Age
53
Location
Southampton UK
Your Mercedes
C43/55 AMG 1999 / C230K 1997
Hi,
Where in the UK ar you? So as someone can recommend a good Independant for you.
 
OP
T

tiggins

New Member
Joined
Jun 21, 2009
Messages
9
Reaction score
0
  • Thread Starter
  • Thread starter
  • #3
yeah it would help thanks for that i am in the rotherham, south yorkshire area of the country. thanks for pointing that out
 


With Turo, you can book and drive any Mercedes you want, wherever you want it, from local hosts across the UK, US, Canada, and Germany. Test drive cars you otherwise might never get a chance to try, or hire something interesting for your next holiday:
www.turo.com
Top Bottom