A40 - No Gear Selector indicator on Dashboard

2005ak

New Member
Joined
Oct 11, 2009
Messages
2
Reaction score
0
Hi all,

First thread so appreciate the help - A140 2001 Fully Auto 47K miles.

Driving home last night and noticed BAS/ESP light followed by engine light and car not doing more than 25 mph - so must be in limp mode.
Changing from P to R to D causes a mighty thud.

Funny thing (well not when it burns a hole in my pocket) was that 'Gear Selector' display on the dashboard went missing and nothing is shown.

Called AA this morning who did some checks but nothing conclusive.

Followed up be calling a Merc Specialist who initially indicated could just be an ABS sensor.
When he did a full diagnostic check it seemed that unable to communicate with Gearbox ECU and thus diagnostic cannot report further on that.
Nice chap who took a lot of time, jacked up car and based on his kit maybe dodgy or loose wire connection with the Gearbox ECU - although he was unable to pull apart so still TBA.

Fault codes amongst other were P1875-000, 001, 002.
CAN Communication is faulty, fault with control unit A1, and with control unit N47 ESP module).
Following sounds bad - Fault in CAN communication with control unit FTC and TAC.

I have read that a recent thread that new gearbox ECU from MB means new GB and thats 3000 squids.
Been told that can fit a g/b ECU independently for about 1200 - but still hurts.

Any previous experience / ideas / help / comments.

Thanks in advance.
 
A

andy@pcd-ltd

Guest
It really needs to go on a star machine to be diagnosed fully.

If you say you have no gear display on the dash it could actually be the selector module that has failed causing it to bang into gear
 
OP
2

2005ak

New Member
Joined
Oct 11, 2009
Messages
2
Reaction score
0
  • Thread Starter
  • Thread starter
  • #3
Thanks Willow132.

Had two diagnostic done now - and the second garage indicates that I get a Auto Electrical specialist to check out the electrics on the car - does make sense in a way.

Another thing I noticed now was that every time I start the car the clock resets to 0:00 - as though the car is being reset every time I start it.

With the garage now and fingers crossed !!
 
A

andy@pcd-ltd

Guest
Yeah sort of makes sense. Does this garage have a star machine to check it with as i have used a couple of diagnostic machines and machines other than the star can somethimes miss of fault codes and problems.

Keep us posted
 

miknik

Member
Joined
Mar 19, 2005
Messages
10
Reaction score
0
Location
Berkshire
Website
www.mercanix.co.uk
Your Mercedes
Vito 111CDI LWB
It really needs to go on a star machine to be diagnosed fully.

If you say you have no gear display on the dash it could actually be the selector module that has failed causing it to bang into gear

Selector module failure on A class normally results in F being displayed on dash. No display at all is usually g/box control unit.
 

hellgrace5

Senior Member
Joined
Jun 8, 2009
Messages
51
Reaction score
1
Sorry to bring this old thread up.
The thread starter and I had the same problem. Car suddenly went no power and no gear indicator on instrument. Fault stored P1875 and P0600.

A large "bang!" occur when going from P to R and to D.

Mine was a A160 W168 Fully auto trans.

Any idea ? Or just the floor shift module and the tranny is acting up ?
 

Cole@MBS

Forum Supporter
Authorised Forum Supporter
Joined
Dec 1, 2008
Messages
13,702
Reaction score
945
Age
53
Location
Southampton
Website
www.mbssouthampton.co.uk
Your Mercedes
124 300 CE 24 Coupe, C220CDI, Porsche 911 4s, Dolomite sprint,
It could be anything from a rpm sensor to the floor shift to a valve body in the box, As Willow says above, it needs to go on to star, guessing otherwise!
 

hellgrace5

Senior Member
Joined
Jun 8, 2009
Messages
51
Reaction score
1
I dont have a Star here and there is no authorized Mercedes dealer here.

Maybe you can help me by identifying what the P0600 & P1875 is ?

I've tried sourcing for a Star but no help here at Papua New Guinea.
 

hellgrace5

Senior Member
Joined
Jun 8, 2009
Messages
51
Reaction score
1
@update

I am at the same situation with 2005ak which I cant get reading into the FTC too.
 

timanfaya43

New Member
Joined
Oct 4, 2010
Messages
2
Reaction score
0
Location
england
Your Mercedes
a class 210 auto
hi.did you get this problem fixed as i have exactly the same fault.
 

hellgrace5

Senior Member
Joined
Jun 8, 2009
Messages
51
Reaction score
1
I have not fix it yet but I have ordered a auto trans and new floor shift. Will update here asap i fix it.
 

lucyyomi

New Member
Joined
Jun 18, 2009
Messages
3
Reaction score
0
Location
Kent
Your Mercedes
A Class
All the info on A140 and gears is worrying! I have a 1999 A140 semi-auto. The gear selector screen does not light up another more. The gears have now stopped working! If I look closely at the indicator, I can faintly see F displayed on the gear selector...Please help! am I going to have to go cap in hand to the bank mgr?!
 

Alex Crow

Senior Member
Joined
Jul 9, 2009
Messages
10,677
Reaction score
46
Location
Super Suffolk
Your Mercedes
W169, W124, w202, W203, KTM 250 EXC, VW T25 camper and a Polo in a pear tree
might be a cheap fix - often just brushes in the ACS control unit fixes it. bang on the top of the passenger side front wing to see if it fixes it temporarily.
 

ELGRINGO

Senior Member
Joined
May 26, 2006
Messages
654
Reaction score
0
Location
fylde coast
Your Mercedes
e230 c180 sl280 brabus a190 smar cart
As above repaired many wiyh new brushes.
 

Avantgarde Automotive, Mercedes-Benz and SLR McLaren specialists. Service, repairs, diagnosis and motorsport preparation.
Unit 14 Hither Green Trading Estate, Clevedon, Somerset, BS21 6XU Tel: 01275 217270 Email:steve@avantgarde-automotive.co.uk
www.avantgarde-automotive.co.uk
Top Bottom