1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

abs/esp fault

Discussion in 'Suspension, Steering & Brakes' started by Alldis, Oct 18, 2012.

  1. Alldis

    Alldis New Member

    Messages:
    7
    Likes Received:
    0
    Joined:
    Jul 20, 2011
    Location:
    Perth Australia
    Your Mercedes:
    ML320 /2000/?
    ML 320 2000:
    Just had a fault diagnosis done by the RAC as having intermitent trouble with shudder noise when braking.
    Diagnosis comments were:
    Tested no grindin noise found when breaking. Inspected F & R Brakes. Pads F&R approx 35% worn. F/dish 26mm/min23mm R/Dish 14.7mm/min13mm

    Can hear noise & feel through brake pedal as if ABS operating. Suspect ABS/ESP fault.
    No warning light on dash.
    Scanned system for codes
    Fault code C1025 can cignals ABS not available.

    Further investigation reg.
    *RF outer cv ? cannot read Leaking onto hub. New Rod(this means I have a new rod as had new rod and crank shaft thinggy recently)

    * cleaned memory/Road test & noise not heard. Montior reg.

    So my question is what should I do from here, and should I have any undue worries re this.?:confused:
     
  2. jibcl500

    jibcl500 Senior Member

    Messages:
    6,420
    Likes Received:
    6
    Joined:
    Oct 22, 2005
    Location:
    Cambridgeshire
    Your Mercedes:
    CL500,ML55,SLK280
    needs star diagnostics first nd then go from there but suspect ABS pump wiring at fault.

    jib
     
  3. television

    television Always remembered RIP

    Messages:
    164,074
    Likes Received:
    310
    Joined:
    Mar 14, 2005
    Location:
    Daventry
    Your Mercedes:
    2002 SL500, 216 CL500, all fully loaded
    I cannot follow this, no warning lamps on but you have the 1025 fault code, was that cleared and still current
     

Share This Page