Accelerator sloppy

col320ce

Active Senior Members
Joined
Jun 23, 2009
Messages
212
Reaction score
12
Location
Australia
Your Mercedes
320CE Sportline
I've just bought a 1993 320CE Sportline (australian) 230 000 km, auto, full MBSH...

The accelerator has a fair amount of movement before the engine starts to go. I have had a look at the accelerator couplings and the cable apears the correct tightness. What happens is that in the 'slack' part of depressing the accelerator there is some movement of the accelerator couplings. It 'looks' like it is the way it should be but 'feels' wrong when driving. Any ideas on this on? Is it correct?
 

meanie

Senior Member
Joined
May 7, 2008
Messages
581
Reaction score
0
Location
Oxon
This sounds pretty normal.
It's a common complaint about MB accelerators,the lack of feel etc.
 

ncooper

Senior Member
Joined
Apr 29, 2009
Messages
421
Reaction score
0
Location
York
Your Mercedes
1984 Mercedes Benz 280 SL,1993 Mercedes Benz 190E Manual,1993 Mercedes Benz 190E Auto
This sounds pretty normal.
It's a common complaint about MB accelerators,the lack of feel etc.

I agree with that wholeheartedly,my 280 SL accelerator is wooden,but when you see how many bars and levers move,its not really surprising:)

Regards,
Nick.
 

Derm

Active Member
Joined
May 4, 2004
Messages
38
Reaction score
0
Hi
I cheated with my 230te and tightened the cable and moved the throttle switch bracket seemed much more responsive!
Derm.
 

WE HAVE NOW MOVED: 8 Hazel Road, Woolston, SO19 7GB
Service, Repairs and remapping service
Any queries, please do not hesitate to contactEmail@mbsofsouthampton.co.ukor alternatively you can phone Colin or Dave on 02380 445820, out of hours numbers are 07787913313 or 07907631681.
Top Bottom