1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Adblue issue

Discussion in 'Engine, Drivetrain, Fuel and Exhaust' started by 30025574, Dec 3, 2019 at 9:59 AM.

  1. 30025574

    30025574 New Member

    Messages:
    6
    Likes Received:
    2
    Joined:
    Tuesday
    Your Mercedes:
    Mercedes e class e220 2.1 bluetec
    Hi all,
    Was wondering if anyone had occurred this issue before. Pictures explain, it came on after one day I started car all warning lights were on told me not to drive or select gear I checked battery voltage. It was 9vollts so change the battery all lights disappeared except EML car ran normally scanned EML issue came up with this and will not clear.
    Help please!
     

    Attached Files:

  2. EmilysDad

    EmilysDad Senior Member

    Messages:
    7,931
    Likes Received:
    1,744
    Joined:
    May 8, 2012
    Location:
    Bury Lancs
    Your Mercedes:
    ML350
    could it be as simple as low level Adblue?

    And welcome to the forum :)
     
    Last edited: Dec 3, 2019 at 10:28 AM
  3. Blobcat

    Blobcat Moderator

    Messages:
    17,339
    Likes Received:
    4,936
    Joined:
    Feb 8, 2006
    Location:
    Near Grange Moor (not Wakefield...)
    Your Mercedes:
    R171 SLK280 3.0, Land Rover 110 County SW
    Hello and welcome,

    How old is the car and do you have any warranty?

    As you have 2.1 in "your Mercedes" then it implies it's 2016 at the newest so out of original MB warranty.

    Hopefully it's as per above although I fear it isn't and that a decent sized bill could be heading your way.
     
  4. John Laidlaw

    John Laidlaw Senior Member

    Messages:
    21,593
    Likes Received:
    6,127
    Joined:
    Nov 15, 2013
    Location:
    Wirral
    Your Mercedes:
    UnMercs BMW i8 Volvo XC90
    Welcome, a feeling this came up recently with a member’s ML or GLE racking my brain but I seem to remember it was a known fault by MB...
     
  5. OP
    30025574

    30025574 New Member

    Messages:
    6
    Likes Received:
    2
    Joined:
    Tuesday
    Your Mercedes:
    Mercedes e class e220 2.1 bluetec
    Hi thank you for the warm welcome and quick responses it's a E class 2014 bluetec 2.1 litre diesel. Fault only came up as soon as battery was gone dead etc adblue tank was 3/4 full and now is full still no luck.
     
  6. OP
    30025574

    30025574 New Member

    Messages:
    6
    Likes Received:
    2
    Joined:
    Tuesday
    Your Mercedes:
    Mercedes e class e220 2.1 bluetec
    Tanks 3/4 full I've filled it up to top no luck
     
  7. OP
    30025574

    30025574 New Member

    Messages:
    6
    Likes Received:
    2
    Joined:
    Tuesday
    Your Mercedes:
    Mercedes e class e220 2.1 bluetec
    Thanks for warm welcome and response
     
  8. Blobcat

    Blobcat Moderator

    Messages:
    17,339
    Likes Received:
    4,936
    Joined:
    Feb 8, 2006
    Location:
    Near Grange Moor (not Wakefield...)
    Your Mercedes:
    R171 SLK280 3.0, Land Rover 110 County SW
    Just having a quick search through the forum and the possible problems are:

    NoX sensors faulty requiring replacement (or blown fuse for NoX sensor)
    AdBlue Injector Fault
    AdBlue Heater Element issues requiring software update
     
    30025574 likes this.
  9. OP
    30025574

    30025574 New Member

    Messages:
    6
    Likes Received:
    2
    Joined:
    Tuesday
    Your Mercedes:
    Mercedes e class e220 2.1 bluetec
    Thanks blob at I will start with fuses as just pit new battery in may have shorted something I'm sure I had a new NOx sensor 6months ago was expensive to lol
     
  10. John Laidlaw

    John Laidlaw Senior Member

    Messages:
    21,593
    Likes Received:
    6,127
    Joined:
    Nov 15, 2013
    Location:
    Wirral
    Your Mercedes:
    UnMercs BMW i8 Volvo XC90
  11. OP
    30025574

    30025574 New Member

    Messages:
    6
    Likes Received:
    2
    Joined:
    Tuesday
    Your Mercedes:
    Mercedes e class e220 2.1 bluetec
    Wighty and John Laidlaw like this.
  12. malcolm210

    malcolm210 Senior Member

    Messages:
    3,637
    Likes Received:
    656
    Joined:
    Aug 21, 2005
    Something to be said for maintaining a 12V supply with the newer Mercs when changing a battery, with this fault in all probability it requires a STAR reset assuming the fuse is ok
     
    Last edited: Dec 3, 2019 at 1:18 PM
    30025574 likes this.
  13. Chrishazle

    Chrishazle Senior Member

    Messages:
    2,834
    Likes Received:
    638
    Joined:
    May 25, 2009
    Location:
    Nr Ashford, Kent
    Your Mercedes:
    S204 2008 C220CDI Elegance Estate Auto, 2008 R171 Facelift SLK280
    Just don't connect the slave battery to the OBD port as a clown at Halfords did when changing the battery on my S204 c220 - lcoked the gearstick in P (had to use the emergency release to get mobile) blew the 12v supply to the OBD port so my indie could not read codes, did something to the secondary power supply to the TCM, cost Halfords £174 at my indie to sort it!
     

Share This Page