advice on my C220 cdi please

neet

Active Member
Joined
Jul 11, 2008
Messages
35
Reaction score
0
Hi All, it's a bit of a weird 1, and I have had a good look through the forum to see if there were any other reports of this, but my C220 cdi coupe pulls away from standstill OK, but then becomes a little sluggish, especially on an incline, until it reaches a higher speed of say 35-40 mph. I also had a rather un-nerving experience on the motorway a few days ago, when I was cruising along and wanted to overtake another car, BUT, I had no instant power when I put my put down, for a few seconds, then all of a sudden the power kicked in. Under normal round town circumtances, it is driving OK, but when I need the oomph it doesn't give it to me! Has anyone else experienced this? It also doesn't like going up a hill either at the moment although it doesn't lose a lot of power it takes a moment to think about it.Until recently, it did the normal thing of dropping down a gear straight away to tackle a hill!

It has done about 89k, just recently had an MOT and has 1000 miles till service A, although I have taken the precaution of booking it in for a service next week.

Thanks in advance for any advice
 

Cole@MBS

Forum Supporter
Authorised Forum Supporter
Joined
Dec 1, 2008
Messages
13,654
Reaction score
812
Age
51
Location
Hedge End, Southampton
Website
www.mbssouthampton.co.uk
Your Mercedes
124 300 CE 24 Coupe, C220CDI, 1959:Morris Minor
Your cheapest route is a short test, it could be many things, its not worth throwing at it with just guess work!!
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Possibly the MAF going down
 
OP
N

neet

Active Member
Joined
Jul 11, 2008
Messages
35
Reaction score
0
  • Thread Starter
  • Thread starter
  • #5
thanks guys, I will wait and see what they tell me on Tuesday!

I have had it out tonight and noticed that in the lower gears the revs will hit the 3k, but after that it doesn't go above the 2k mark, even though the speed is picking up quite nicely! And in neutral with the accelerator to the floor, it doesn't go above the 3k mark!

xx
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
thanks guys, I will wait and see what they tell me on Tuesday!

I have had it out tonight and noticed that in the lower gears the revs will hit the 3k, but after that it doesn't go above the 2k mark, even though the speed is picking up quite nicely! And in neutral with the accelerator to the floor, it doesn't go above the 3k mark!

xx

As it cost nothing why not unplug the MAF and see if it goes any better
 
OP
N

neet

Active Member
Joined
Jul 11, 2008
Messages
35
Reaction score
0
  • Thread Starter
  • Thread starter
  • #7
what will that do?????? You must excuse my ignorance as I am a girly :lol:
 

jberks

Senior Member
Joined
May 12, 2004
Messages
11,145
Reaction score
23
Location
M1, Outside lane, somewhere between Leeds and Lond
Your Mercedes
Jaguar XF 3.0 S, LR Freelander 2, Fiat 500 & Fiat Panda
thanks guys, I will wait and see what they tell me on Tuesday!

I have had it out tonight and noticed that in the lower gears the revs will hit the 3k, but after that it doesn't go above the 2k mark, even though the speed is picking up quite nicely! And in neutral with the accelerator to the floor, it doesn't go above the 3k mark!

xx

Thats Safe or 'Get you home' mode. Its hit 3000rpm, something reports a fault and the engine computer turns everything but the most essential stuff off. Its remarkable how well they pick up with no turbo or clevertrickery working isn't it!
With a bit of luck, it should have logged the fault and a merc trained/equipped garage will be able to interrogate the computer and diagnose it. The MAF does this (exactly what mine did when my MAF went) but equally as has been said, there are other possible causes.
 

achohan

Active Member
Joined
Aug 15, 2009
Messages
39
Reaction score
0
Location
Bexhill on Sea
Your Mercedes
E220 Estate 7 Seater 2002
Sounds exactly the same issue I'm having with my E220, won't rev above 3000 and is guttles. Mines due into the garage this Thursday to be hooked up to their equipment. I'll let you know how I get on in case its of some help.

Cheers;)
 

Ian Till

New Registration
Joined
Sep 14, 2009
Messages
1
Reaction score
0
I had a similar problem with my W210 E220 CDI - at that time, Dieselman suggested I might test the MAF and I then replaced it, cost iirc £65 from MB for just the sensor (not the housing) and the car was as right as rain again.

My money would be on the MAF sensor.

BTW, I'm new here, but not new to forums, so hello. :)

Ian.
 

Alex Crow

Senior Member
Joined
Jul 9, 2009
Messages
10,677
Reaction score
40
Location
Super Suffolk
Your Mercedes
W169, W124, w202, W203, KTM 250 EXC, VW T25 camper and a Polo in a pear tree
hello ian, welcome to our world.
 

Cole@MBS

Forum Supporter
Authorised Forum Supporter
Joined
Dec 1, 2008
Messages
13,654
Reaction score
812
Age
51
Location
Hedge End, Southampton
Website
www.mbssouthampton.co.uk
Your Mercedes
124 300 CE 24 Coupe, C220CDI, 1959:Morris Minor
I had a similar problem with my W210 E220 CDI - at that time, Dieselman suggested I might test the MAF and I then replaced it, cost iirc £65 from MB for just the sensor (not the housing) and the car was as right as rain again.

My money would be on the MAF sensor.

BTW, I'm new here, but not new to forums, so hello. :)

Ian.


Hello:D:D:D
 

Blakey

Senior Member
Joined
Oct 11, 2007
Messages
295
Reaction score
1
Location
Brighton UK
Your Mercedes
C180 Sport (12) Blueefficiency
And hello and welcome from me too! :)
 

Blakey

Senior Member
Joined
Oct 11, 2007
Messages
295
Reaction score
1
Location
Brighton UK
Your Mercedes
C180 Sport (12) Blueefficiency
How that car running now then Blakey with its new mounts and new G/box oil??

Hello Cole! I don't like to tempt fate but it's running beautifully smoothly and I haven't had a single bit of trouble with the gearbox since, thanks to you and Dave. :D:D

Cheers Matey!
 

Cole@MBS

Forum Supporter
Authorised Forum Supporter
Joined
Dec 1, 2008
Messages
13,654
Reaction score
812
Age
51
Location
Hedge End, Southampton
Website
www.mbssouthampton.co.uk
Your Mercedes
124 300 CE 24 Coupe, C220CDI, 1959:Morris Minor
Hello Cole! I don't like to tempt fate but it's running beautifully smoothly and I haven't had a single bit of trouble with the gearbox since, thanks to you and Dave. :D:D

Cheers Matey!


Thats the only answer im happy with!!!

Nice one!!:D:D
 

Blakey

Senior Member
Joined
Oct 11, 2007
Messages
295
Reaction score
1
Location
Brighton UK
Your Mercedes
C180 Sport (12) Blueefficiency
Thats the only answer im happy with!!!

Nice one!!:D:D

Oh but that drivers door window switch is up to it's old tricks again :(

I'll have it out again at some point and check for poor solder joints.

Sorry neet, we seem to have hijacked your thread. I hope you get your problem sorted out. :)
 
OP
N

neet

Active Member
Joined
Jul 11, 2008
Messages
35
Reaction score
0
  • Thread Starter
  • Thread starter
  • #18
hahaha, apology accepted Blakey :):)

Well, I had it serviced, and still no better (it was due anyway, pure fluke!) I am having it looked at tomorrow, but from all accounts, it does sound like the MAF.

I will let you all know what happens:) I need it right for Sunday or I will have to "borrow" the in-laws car as I am travelling some distance:(
 

Blakey

Senior Member
Joined
Oct 11, 2007
Messages
295
Reaction score
1
Location
Brighton UK
Your Mercedes
C180 Sport (12) Blueefficiency
hahaha, apology accepted Blakey :):)

Well, I had it serviced, and still no better (it was due anyway, pure fluke!) I am having it looked at tomorrow, but from all accounts, it does sound like the MAF.

I will let you all know what happens:) I need it right for Sunday or I will have to "borrow" the in-laws car as I am travelling some distance:(

Any improvement then? Did they find a problem?
 
OP
N

neet

Active Member
Joined
Jul 11, 2008
Messages
35
Reaction score
0
  • Thread Starter
  • Thread starter
  • #20
well, I now have a car that is running brilliantly, thanks everyone! The MAF was disconnected, and no difference. Ordered a new 1 from car parts (66 quid all in) arrived the next day, changed it, and bobs your uncle! It runs a dream again, and I LOVE it!!!!!!!
 


Over 100 branches Nationwide, More than 114,000 Parts in Stock, The UKs Largest, and Fastest Growing Parts Supplier,please see MBO Members’ Area for discount codeEuro Car Parts Ltd
Top Bottom