any ideas anyone?

Vee8

Member
Joined
Feb 27, 2009
Messages
22
Reaction score
0
Location
Chorley Lancs UK
Your Mercedes
SL 350 pano
Hi,
I recently asked the question on ideas on a 430 CLK not starting. I forgot to say it was when warm.When it cools off it's fine.
Now the problem has progressed to conking out while I'm driving.If I wait an hour(like I did for the breakdown service to arrive!) it starts again but won't go for long.It seems to be getting fuel but I'm not certain.Is this a MAF problem?
 
OP
V

Vee8

Member
Joined
Feb 27, 2009
Messages
22
Reaction score
0
Location
Chorley Lancs UK
Your Mercedes
SL 350 pano
  • Thread Starter
  • Thread starter
  • #3
Many thanks for the very quick response.You've got me reading up on it now.Another thread elsewhere reckons the symptoms are of a camshaft sensor failure.What's the difference? I guess there is only one way to find out for sure and that is to get it onto a diagnostic.
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
331
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Many thanks for the very quick response.You've got me reading up on it now.Another thread elsewhere reckons the symptoms are of a camshaft sensor failure.What's the difference? I guess there is only one way to find out for sure and that is to get it onto a diagnostic.

The chances are this will not show up on STAR,,as they never do, Camshaft sensor suffer oil leaks and not the same.

This will be the CPS and very common,,it measure 1k ohms when good and O/C when bad (hot)
 
OP
V

Vee8

Member
Joined
Feb 27, 2009
Messages
22
Reaction score
0
Location
Chorley Lancs UK
Your Mercedes
SL 350 pano
  • Thread Starter
  • Thread starter
  • #6
Thanks for all your help guys.Youv'e turned a crisis into something more manageable.
 

Use the code MERCEDES and get 10% MBO Club Discount, oilman's website:www.opieoils.co.uk

register for news and offers email:sales@opieoils.co.ukphone: 01209 202944
Top Bottom