1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Battery Warning Light Visit Workshop

Discussion in 'Electrics, Vacuum, Ignition and ECU' started by E320 CDI Alex, Feb 19, 2012.

  1. E320 CDI Alex

    E320 CDI Alex New Member

    Messages:
    2
    Likes Received:
    0
    Joined:
    Feb 19, 2012
    Location:
    Chesterfield
    Your Mercedes:
    E Class 320 CDI 2005
    My E320 CDI (2005/ 134,000 miles) has is showing the RED Battery warning light visit workshop on 2 occasions?

    It has shown it twice when started up in the morning. If I run it for less than 5 mins... stop it..... and start it again it does not show the warning light any further. I thought this might initially be a random ignorable issue but.....

    After driving 100 miles the command system computer crackled and went black on the motorway... everything else seemed fine and it started itself back up about 10 seconds later.

    Power steering and brakes seem ok at the moment. I use this car a lot and could do without a more major issue on the motorway.

    Is this the start of the alternator failing? Or is it likely to be something less major?

    I would be very grateful of any advice?

    Kind regards, Alex
     
    Last edited: Feb 19, 2012
  2. panason1c

    panason1c Senior Member

    Messages:
    1,927
    Likes Received:
    6
    Joined:
    Apr 19, 2004
    Location:
    Somerset, UK
    Your Mercedes:
    Mercedes ML270CDI, VW Polo 1.9tdi, BMW K1200RS
    I would have the battery checked first, if it's the original battery then it's probably seen better days by now.
     
  3. television

    television Always remembered RIP

    Messages:
    164,074
    Likes Received:
    309
    Joined:
    Mar 14, 2005
    Location:
    Daventry
    Your Mercedes:
    2002 SL500, 216 CL500, all fully loaded
    This will be the brush pack possibly just worn out, it will not be the battery as this cannot turn on the charging lamp

    The brush packs can be fitted to most alternators, yours may a water cooled one not repairable
     
  4. OP
    E320 CDI Alex

    E320 CDI Alex New Member

    Messages:
    2
    Likes Received:
    0
    Joined:
    Feb 19, 2012
    Location:
    Chesterfield
    Your Mercedes:
    E Class 320 CDI 2005
    Had it checked

    Thanks for the advice.... I had it checked today.

    In idle the Alternator was kicking out - 13.8
    The battery was reading without engine running - 10.6

    Any advice from here.... what should the battery be showing?

    Does it sound like a new battery should cure it?

    Many thanks in advance.

    Alex
     
  5. panason1c

    panason1c Senior Member

    Messages:
    1,927
    Likes Received:
    6
    Joined:
    Apr 19, 2004
    Location:
    Somerset, UK
    Your Mercedes:
    Mercedes ML270CDI, VW Polo 1.9tdi, BMW K1200RS
    10.6v is too low, as i said in previous post, if its the original battery, renew it.
     
  6. television

    television Always remembered RIP

    Messages:
    164,074
    Likes Received:
    309
    Joined:
    Mar 14, 2005
    Location:
    Daventry
    Your Mercedes:
    2002 SL500, 216 CL500, all fully loaded
    As above and dead right voltage for one dead cell
     
  7. Mallo

    Mallo Active Senior Members

    Messages:
    79
    Likes Received:
    15
    Joined:
    Mar 21, 2010
    Location:
    Newcastle
    Your Mercedes:
    '11 W221 S500
    I just had the same warning red battery visit workshop (disappeared on restart of the car) -just popped up to the garage and the alternator was 13.8. Should have checked the battery with the engine off, will probably be that.

    Glad I found this thread :)
     
  8. bc100

    bc100 Senior Member

    Messages:
    206
    Likes Received:
    39
    Joined:
    Apr 10, 2010
    Location:
    South Devon
    Your Mercedes:
    W205 C250 BluTec Estate 2014
    I also have had the red warning about the battery/alternator a few days ago including a message to turn off load items. I managed to get home and after a few days of non use I just checked the voltage and it was about 11V. When I start the car it drops to 10.5 and then slowly goes up to 12V. At around 2000RPM I get 14.2Volts. The car has always started first time every time all through winter. It is only used during the weekend but last week I did a 250 mile round trip mostly on the motorway, so the battery should be charged. The care is 11 years old and does not have a Mercedes brand battery in it so I assume it may be on its second or third battery. Have I got a battery or alternator problem and what is the life expectancy of a battery these days? I got 11 years from my Volvo battery some years ago.
     
  9. television

    television Always remembered RIP

    Messages:
    164,074
    Likes Received:
    309
    Joined:
    Mar 14, 2005
    Location:
    Daventry
    Your Mercedes:
    2002 SL500, 216 CL500, all fully loaded
    You never know with batteries,,,many fail at 3 months and others 10 years.

    The main thing is get a good make like Exide,Lucas,Varta, Bosch or banner,

    House name batteries such as Halfords are a pain in the back side

    The average life is 5 years
     
  10. bc100

    bc100 Senior Member

    Messages:
    206
    Likes Received:
    39
    Joined:
    Apr 10, 2010
    Location:
    South Devon
    Your Mercedes:
    W205 C250 BluTec Estate 2014
    I have just gone out and re checked voltages and it is now telling me that the no run voltage is 12V and the running voltage is 11.9 V! This is at around 2000RPM and within a few seconds I get the red warning unlike the time of my earlier post, so it seems i may have an intermittent alternator problem.
     
  11. television

    television Always remembered RIP

    Messages:
    164,074
    Likes Received:
    309
    Joined:
    Mar 14, 2005
    Location:
    Daventry
    Your Mercedes:
    2002 SL500, 216 CL500, all fully loaded
    Yes the reg pack has failed or the brushes worn
     
  12. bc100

    bc100 Senior Member

    Messages:
    206
    Likes Received:
    39
    Joined:
    Apr 10, 2010
    Location:
    South Devon
    Your Mercedes:
    W205 C250 BluTec Estate 2014
    Just popped the car round to Klasse and he has ordered a new reg pack for Monday, so I'll let you know. Managed to fill the car with petrol as I was almost empty and the queues were surprisingly non existent here in Fulham!
     
  13. gen251

    gen251 Member

    Messages:
    13
    Likes Received:
    0
    Joined:
    Apr 24, 2010
    hi Guys My mates merc battery is dead but cannot find where the battery is located. found small one passenger side with 12volts but that is obviously the main one . Any help welcomed
     
  14. Naraic

    Naraic Moderator

    Messages:
    10,328
    Likes Received:
    942
    Joined:
    Mar 4, 2010
    Your Mercedes:
    2005 CL500.
    Even better if we knew what your mate drove.
     
  15. gen251

    gen251 Member

    Messages:
    13
    Likes Received:
    0
    Joined:
    Apr 24, 2010
    merc battery

    sorry guys E320 CDI 06 plate

    battery in front OK - for brakes

    Its the main one. Not under back seat - so where also is there a point in engine compatment where can charge battery.

    Sorry about that
    Frustrated
     
  16. Mallo

    Mallo Active Senior Members

    Messages:
    79
    Likes Received:
    15
    Joined:
    Mar 21, 2010
    Location:
    Newcastle
    Your Mercedes:
    '11 W221 S500
    Would be interesting to see if that was it - I've only had the error once more in 500 miles. I'm off to get both batteries tested today and if they're ok I'll have to take it to Merc as I need a courtesy car to get to work.
     
  17. Mallo

    Mallo Active Senior Members

    Messages:
    79
    Likes Received:
    15
    Joined:
    Mar 21, 2010
    Location:
    Newcastle
    Your Mercedes:
    '11 W221 S500
    In the boot next to the spare wheel - pull the floor up then pull up the felt lining - it should be on the right.
     
  18. Mallo

    Mallo Active Senior Members

    Messages:
    79
    Likes Received:
    15
    Joined:
    Mar 21, 2010
    Location:
    Newcastle
    Your Mercedes:
    '11 W221 S500
    Well the batteries were given a clean bill of health so I'm going to have to go to Merc as nowhere near my work really wants to touch it now.

    That's fine I can book it in next week but I've got a trip to Aberdeen and back over the weekend so my question is should I be ok or are these things prone to sudden failure after a few (it's been 2 in 600 miles now - only warning light no electrical shutdowns) hiccups.

    Thanks

    Simon
     
  19. television

    television Always remembered RIP

    Messages:
    164,074
    Likes Received:
    309
    Joined:
    Mar 14, 2005
    Location:
    Daventry
    Your Mercedes:
    2002 SL500, 216 CL500, all fully loaded
    The fault could be with the battery converter box,,, if the running voltage is over 13.8 it should be OK, there is a software update for these
     
  20. Mallo

    Mallo Active Senior Members

    Messages:
    79
    Likes Received:
    15
    Joined:
    Mar 21, 2010
    Location:
    Newcastle
    Your Mercedes:
    '11 W221 S500
    Thanks Malcolm,

    It was 13.8 when we tested it last week, so maybe it's just the software update required. Will book it in anyway next week.
     

Share This Page