C 240 engine failed to start

bc100

Senior Member
Joined
Apr 10, 2010
Messages
262
Reaction score
57
Location
South Devon
Your Mercedes
S205 C250 BluTec Estate 2014
For the first time in three years the engine would not start this morning within the first couple of seconds. Eventually on the 6th attempt it started straight away as usual. I now have the engine symbol on (not the graphic version that can be cleared). The car is still running very well. Two days ago it went in to have a rattle investigated that turned out to be parking brake cables on the exhaust so the exhaust was removed, I think, then cables secured and exhaust replaced.

Battery seemed very healthy as it was trying to start the car

Am I safe to continue driving?

Round town in London this afternoon the car is now starting first time every time and behaving well in all other ways.
 

grober

Senior Member
Joined
May 15, 2002
Messages
2,946
Reaction score
27
Location
Scotland
Your Mercedes
W204 C200cdi estate
You need to get the car on a STAR DIAGNOSTIC system to get any stored fault codes read if the engine warning light remains on. I wonder if any of the lambda sensor/s were disturbed when the exhaust was removed?
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
341
Age
87
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
As Grober really, quite possible and this could turn the lamp on again and that should go out on its own once running OK. A good hard drive normally knocks the lamp off turned on probably by the 02 sensor in replying to the Lambda
 
OP
B

bc100

Senior Member
Joined
Apr 10, 2010
Messages
262
Reaction score
57
Location
South Devon
Your Mercedes
S205 C250 BluTec Estate 2014
  • Thread Starter
  • Thread starter
  • #4
Would this explain the starting problem?
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
341
Age
87
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Would this explain the starting problem?

Yes the starting mixture could have been confused. Just see what happens, the lamp should go out on its own
 
OP
B

bc100

Senior Member
Joined
Apr 10, 2010
Messages
262
Reaction score
57
Location
South Devon
Your Mercedes
S205 C250 BluTec Estate 2014
  • Thread Starter
  • Thread starter
  • #6
Thanks, I'm going down to Hastings tomorrow and I'll let you know on my return.
 

star

Forum Supporter
Authorised Forum Supporter
Joined
Oct 6, 2004
Messages
6,038
Reaction score
1,577
Location
Reading
Your Mercedes
Smart + others :)
Get the codes read, lambdas shouldn't affect starting as they don't start to working till their warmed up.
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
341
Age
87
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Get the codes read, lambdas shouldn't affect starting as they don't start to working till their warmed up.

Yes agreed, but they could have upset the mixture on the way home from getting the work done, that was my thoughts and it does take a time for the 02 sensor to get back to normal.

Just my thoughts;)
 

Pathfinder

Senior Member
Joined
Dec 21, 2011
Messages
814
Reaction score
18
Age
61
Location
Gourock
Your Mercedes
CLC 220 CDi Sport Diesel Year 2008
Crank shaft position sensor?
 
OP
B

bc100

Senior Member
Joined
Apr 10, 2010
Messages
262
Reaction score
57
Location
South Devon
Your Mercedes
S205 C250 BluTec Estate 2014
  • Thread Starter
  • Thread starter
  • #10
Well, we didn't get to Hastings but ended up about a half hours drive away and then back via a clogged M25 (on Sunday afternoon!) and all went well. Engine warning symbol was not on the next morning and did not re-appear. Drove the seven miles to work and back today and all OK. I'll let you know if there are any developments.

Thanks to the forum, or I could have had an expensive trip back to the menders.
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
341
Age
87
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
You should be OK now relax :D:D
 
OP
B

bc100

Senior Member
Joined
Apr 10, 2010
Messages
262
Reaction score
57
Location
South Devon
Your Mercedes
S205 C250 BluTec Estate 2014
  • Thread Starter
  • Thread starter
  • #12
Interesting development on this. I had dropped the car in to my local Mercedes specialist for a parking brake adjustment and mentioned the non start. He came back to me later that day saying the crank sensor was on its way out. He has replaced it and everything is still working well. I had hoped I had got off lightly but it was not to be.
 

Pathfinder

Senior Member
Joined
Dec 21, 2011
Messages
814
Reaction score
18
Age
61
Location
Gourock
Your Mercedes
CLC 220 CDi Sport Diesel Year 2008
Well I got that one right for a change !
 
OP
B

bc100

Senior Member
Joined
Apr 10, 2010
Messages
262
Reaction score
57
Location
South Devon
Your Mercedes
S205 C250 BluTec Estate 2014
  • Thread Starter
  • Thread starter
  • #14
As ever, I'm grateful for the helpful (and often very quick) replies
 


ALL MBO Club members qualify for 15% discount on second hand parts.Please see MBO Members’ Area for discount codewww.dronsfields.com
Top Bottom