c180 203 engine whine when cold

merc300e

Senior Member
Joined
Aug 25, 2004
Messages
93
Reaction score
0
Location
Manchester UK
hello - I have a 2001 c180 2.0 - when cold there is a loud whirring noise which disappears as the engine heats up. Seems to come centrally from the engine front? Strangely it continues for a few seconds when the engine is switched off. Even stalling the engine to stop it fast when switched off the sound continues for a few seconds - slowing to a stop within 4 seconds it sounds very fast like a belt tensioner pulley would but why does it not stop with the engine? the electric fan is not running. Switching air con on/off makes no difference. - car has done 76000 with full indi SH
 
Last edited:

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
I am not sure on this one but you could have an Aux air pump and this could cause the sound that you can hear
 

Alex Crow

Senior Member
Joined
Jul 9, 2009
Messages
10,677
Reaction score
40
Location
Super Suffolk
Your Mercedes
W169, W124, w202, W203, KTM 250 EXC, VW T25 camper and a Polo in a pear tree
as malcolm says, this is most likely to be your aux air pump, mounted near your alternator i believe. it just pumps air into the exhaust to help the cat and emissions.
 
OP
merc300e

merc300e

Senior Member
Joined
Aug 25, 2004
Messages
93
Reaction score
0
Location
Manchester UK
  • Thread Starter
  • Thread starter
  • #5
Thanks

Thanks for that, I do now think it is the air pump as not much else carries on after the engine has stopped and it only lasts for 30 seconds when started from cold. I will change and report back.
 

WE HAVE NOW MOVED: 8 Hazel Road, Woolston, SO19 7GB
Service, Repairs and remapping service
Any queries, please do not hesitate to contactEmail@mbsofsouthampton.co.ukor alternatively you can phone Colin or Dave on 02380 445820, out of hours numbers are 07787913313 or 07907631681.
Top Bottom