1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

C220 CDI Coupe Electrical Problem

Discussion in 'Electrics, Vacuum, Ignition and ECU' started by ed021, Dec 6, 2012.

  1. ed021

    ed021 New Member

    Messages:
    4
    Likes Received:
    0
    Joined:
    Dec 6, 2012
    Location:
    Glasgow
    Your Mercedes:
    C220 CDI Coupe
    Hi Guys. I just bought a 03 Plate C220 CDI Coupe yesterday as I have always wanted one. It worked fine last night but when I started it this morning the Speedo, Rev Counter, fuel gauge, Window Wipers and Indicators wont come on. The engine starts fine and it drives ok except I don't know how fast Im going etc :lol: The dash lights up but the on-board computer doesn't seem to work?

    Can anyone help as I dont know a thing about cars.:confused:

    Thanks
     
  2. television

    television Always remembered RIP

    Messages:
    164,074
    Likes Received:
    309
    Joined:
    Mar 14, 2005
    Location:
    Daventry
    Your Mercedes:
    2002 SL500, 216 CL500, all fully loaded
    This does look to be an EIS problem (ignition switch), I would get it checked out on STAR,if it is that come back and we will put you in touch with Mark a member here who deals in these things
     
  3. Mark@RMK

    Mark@RMK Senior Member Authorised Forum Supporter

    Messages:
    534
    Likes Received:
    8
    Joined:
    Jan 4, 2010
    Location:
    Birmingham
    Your Mercedes:
    115CDi Vito
    Does it do it with both keys?
     
  4. OP
    ed021

    ed021 New Member

    Messages:
    4
    Likes Received:
    0
    Joined:
    Dec 6, 2012
    Location:
    Glasgow
    Your Mercedes:
    C220 CDI Coupe
    Thanks guys. I only got the one key with it unfortunately. I am taking it to a garage tomorrow so will hopefully find out a but more then.
     
  5. OP
    ed021

    ed021 New Member

    Messages:
    4
    Likes Received:
    0
    Joined:
    Dec 6, 2012
    Location:
    Glasgow
    Your Mercedes:
    C220 CDI Coupe
    Just noticed another weird thing there. When the key in first placed into the ignition the dash lights come on and the fuel gauge rises. When I turn the ignition on the fuel gauge drops again to its default position. Dont know if that means anything but I thought it was a bit weird :lol:

    Like I said I appreciate you guys taking the time to reply.
     
  6. television

    television Always remembered RIP

    Messages:
    164,074
    Likes Received:
    309
    Joined:
    Mar 14, 2005
    Location:
    Daventry
    Your Mercedes:
    2002 SL500, 216 CL500, all fully loaded
    I do not think it can be much other than the switch, it always a pleasure to try and help :D
     
  7. OP
    ed021

    ed021 New Member

    Messages:
    4
    Likes Received:
    0
    Joined:
    Dec 6, 2012
    Location:
    Glasgow
    Your Mercedes:
    C220 CDI Coupe
    Got the Car to a Mechanic and he has advised me its the EIS. I'm advised this can be expensive as it needs programmed and things.

    Interestingly we discovered that if we leave the key in the ignition at the second position for about 10-15 seconds it seems to work......bit weird but don't know how long it will last! :roll:
     
  8. television

    television Always remembered RIP

    Messages:
    164,074
    Likes Received:
    309
    Joined:
    Mar 14, 2005
    Location:
    Daventry
    Your Mercedes:
    2002 SL500, 216 CL500, all fully loaded
    Then what I said, you could try leaving the key in for up to 90 mins, but Mark knows this fault and I am sure he can fix it
     
  9. Alex Crow

    Alex Crow Senior Member

    Messages:
    10,677
    Likes Received:
    33
    Joined:
    Jul 9, 2009
    Location:
    Super Suffolk
    Your Mercedes:
    W169, W124, w202, W203, KTM 250 EXC, VW T25 camper and a Polo in a pear tree
    I suspect it is indeed a key fault, as Mark suggests.
     
  10. Roney

    Roney New Member

    Messages:
    9
    Likes Received:
    0
    Joined:
    Nov 21, 2012
    Location:
    Worcester UK
    Your Mercedes:
    E320 CDI Sport 2005
    I have the same problem on my E class 211. I have had the key tested and have had a new Ignition switch fitted. Sadly all to no avail. I have had the ECU and the instrument cluster tested. The problem still exists. I am reliably informed that the problem must be in the instrument cluster.:(
     
  11. Alex Crow

    Alex Crow Senior Member

    Messages:
    10,677
    Likes Received:
    33
    Joined:
    Jul 9, 2009
    Location:
    Super Suffolk
    Your Mercedes:
    W169, W124, w202, W203, KTM 250 EXC, VW T25 camper and a Polo in a pear tree
    How many keys do you have?

    If you have more than one, do you have a problem when using both?
     
  12. Roney

    Roney New Member

    Messages:
    9
    Likes Received:
    0
    Joined:
    Nov 21, 2012
    Location:
    Worcester UK
    Your Mercedes:
    E320 CDI Sport 2005
    Two Keys, I have been to Mark at RMK.
     
  13. television

    television Always remembered RIP

    Messages:
    164,074
    Likes Received:
    309
    Joined:
    Mar 14, 2005
    Location:
    Daventry
    Your Mercedes:
    2002 SL500, 216 CL500, all fully loaded
    Mark has posted on the faulty about if you warm the switch it works
     
  14. Roney

    Roney New Member

    Messages:
    9
    Likes Received:
    0
    Joined:
    Nov 21, 2012
    Location:
    Worcester UK
    Your Mercedes:
    E320 CDI Sport 2005
    This is Intermitent and usually sorts itself 2nd or 3rd try if you remove the key then re start. Although maybe a red herring when the fault occurs the cooling fan races.
     

Share This Page