1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

C220 ESP currently unavailable when putting foot down (automatic)

Discussion in 'Engine, Drivetrain, Fuel and Exhaust' started by Omar Noori, Apr 27, 2018.

  1. Omar Noori

    Omar Noori New Member

    Messages:
    2
    Likes Received:
    0
    Joined:
    Apr 27, 2018
    Your Mercedes:
    Mercedes C220 CDI Sport 2007 (57 plate)
    Hi everyone

    So I've had this problem for a while. The car runs perfectly most of the time, there is only a particular time when this problem happens. After driving on the motorway for around half an hour and when I need to overtake someone, I put my foot down to get a boost and it doesn't downshift a gear, instead I get the error message 'ESP currently unavailable, please see owner's manual'. The amber engine management light comes on as well as the yellow warning triangle. The car doesn't lose power or slow down, I can still pick up speed at a slower rate, but the car won't drop a gear for that extra boost. When I turn the car off and on again, the warning message disappears but the engine management light stays on, eventually that turns off too. This never happens when I put my foot down when I'm driving inner city, it only happens after trying to put my foot down after driving on the motorway for at least 20 minutes or so. I didn't have any work down prior to this problem starting it was very out of the blue. Since it has happened, I've had (and passed an MOT), had a service from kwik fit, changed the front driver suspension, changed the rear driver brake caliper and rear brake pads, my tyre pressures are fine. Has anyone had this problem before or any idea what it could be?
     
  2. nufc1975

    nufc1975 Member

    Messages:
    17
    Likes Received:
    0
    Joined:
    Feb 13, 2018
    Your Mercedes:
    C220 Sport Estate 2008
    I have exact same issue! Will let you know if I get any help. Even had the suspension & brake pad works done!

    Mine happened this morning. Light on & then a sort of semi limp mode. Car drives but won't accelerate fast past about 20-30 mph.
     
  3. OP
    Omar Noori

    Omar Noori New Member

    Messages:
    2
    Likes Received:
    0
    Joined:
    Apr 27, 2018
    Your Mercedes:
    Mercedes C220 CDI Sport 2007 (57 plate)
    Is it the first time this has happened? With mine, the cruise control doesn't work either. Strangely no error messages came up when I took it to the mechanic, he told me to bring it to him when the error lights are on which is difficult because they turn off when I switch the car off.
     
  4. nufc1975

    nufc1975 Member

    Messages:
    17
    Likes Received:
    0
    Joined:
    Feb 13, 2018
    Your Mercedes:
    C220 Sport Estate 2008
    Yes, first time. I have a misalignment in steering wheel which I wonder might be causing it.
     

Share This Page