C240 not starting

M

Mikeju53

Guest
Good afternoon, everyone, I'm a new member and I hope you can help me!!

My brother-in-law's S reg C240 Elegance has been parked at our house for the last 2 years after he emigrated to Hong Kong. The idea was that he would use it during return visits but that never happened and it has been Sorn for the past 12 months. He has now decided to sell it so asked me if I would get it taxed and MOT'ed. I charged the battery and, more in hope than anything else, tried to start it.

After about 4 - 5 seconds the engine fired and picked up, but then fell back to a very slow lumpy idle for about 20 secs and stopped. This happened the next couple of times but now it won't run after initial firing. It sounds like a fuel issue to me and, having searched this forum, fuel pump relay sounds like a possibility. However, I know nothing about Mercs and thought I would seek advice from the experts before plunging in. Is there anything else I should check first or is the relay the most likely starting point?? If so, where is it??


Many tks
Mike
 

Cole@MBS

Forum Supporter
Authorised Forum Supporter
Joined
Dec 1, 2008
Messages
13,654
Reaction score
812
Age
51
Location
Hedge End, Southampton
Website
www.mbssouthampton.co.uk
Your Mercedes
124 300 CE 24 Coupe, C220CDI, 1959:Morris Minor
Fuel pump relay! next to the battery, next to the rear fuse box! only one there,

Welcome to the forums
 
OP
M

Mikeju53

Guest
  • Thread Starter
  • Thread starter
  • #3
Right. I found the relay, took it out and tested it. It seems to be working normally but the car still isn't. I've tried listening for the fuel pump. It seems to operate sometimes but not others. Should it run each time the ignition is turned on?

Another thing I thought about was sticking injectors, particularly as it has been standing a long time. But if they are acting up, why did the car start normally and run for a few secs?

Any ideas, anyone??
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
The fuel pump will run each time the ignition is turned on for a few seconds and then stops.

You can over ride the fuel pump relay by leaving it out and bridging pins 7 and 8
 

Alex Crow

Senior Member
Joined
Jul 9, 2009
Messages
10,677
Reaction score
40
Location
Super Suffolk
Your Mercedes
W169, W124, w202, W203, KTM 250 EXC, VW T25 camper and a Polo in a pear tree
his relay will not have 8 pins malcolm.

you need to bridge the terminals 30 and 87 in the relay socket.
 
OP
M

Mikeju53

Guest
  • Thread Starter
  • Thread starter
  • #9
Thanks gents, I've got some stuff to try. The battery's not got enough juice to turn the engine at the moment (hardly surprising after that long without being used) but I'll try it again on Friday. Watch this space!!

Is there a preferred ie easy, way to drain the fuel??

Do I need to bleed anything afterwards??
 
OP
M

Mikeju53

Guest
  • Thread Starter
  • Thread starter
  • #12
I'll give you the car and a tenner for yours:D:D
 

We are a completely independent Mercedes Benz service, Mercedes repair and Mercedes MOT centre located in Warrington, Cheshire and have been established since April 2006. All servicing carried out by MB Tech is in accordance with manufacturer service schedules and carried out by Mercedes Benz trained mechanics.
Contact MB-TECH on 01925 653050 or visitwww.mercedesservicingwarrington.co.uk
Top Bottom