Drivers Seat back stuck in the horizontal position

alanuk400

Senior Member
Joined
Feb 2, 2006
Messages
215
Reaction score
1
Location
Belfast NI
Website
www.vipsec.co.uk
Your Mercedes
2016 W222 Mercedes S-Class LWB
Hi

My 03 W220 Drivers seat has stuck in the horizontal position, I put it back to clean it and thought it went back further than it should, now it only lifts up about an inch and then stops.

So the motor is ok, there is nothing caught in the gears,they turn about three full revolutions, when it stops you can hear the relay clicking.

It's as if it thinks it is in the upright position.

Thanks

Alan
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
331
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
I have a feeling that you will have to take it out, dismantle it and put it back together in the upright position.

I can provide you with some papers
 
OP
alanuk400

alanuk400

Senior Member
Joined
Feb 2, 2006
Messages
215
Reaction score
1
Location
Belfast NI
Website
www.vipsec.co.uk
Your Mercedes
2016 W222 Mercedes S-Class LWB
  • Thread Starter
  • Thread starter
  • #3
I have a feeling that you will have to take it out, dismantle it and put it back together in the upright position.

I can provide you with some papers

I left it up to my indie today and he put it on star, it didn't come up with any fault, he said it might be a sensor thinking it is upright, he is going to do what you have suggested.

Is there a reset procedure to try, ie 5 seconds at the end of each travel.

Alan
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
331
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
The seat has gone past the sensor, and is operating in the wrong sensor mode, by removing a sensor then running the motor to get the back upright should cure it
 
OP
alanuk400

alanuk400

Senior Member
Joined
Feb 2, 2006
Messages
215
Reaction score
1
Location
Belfast NI
Website
www.vipsec.co.uk
Your Mercedes
2016 W222 Mercedes S-Class LWB
  • Thread Starter
  • Thread starter
  • #5
The seat has gone past the sensor, and is operating in the wrong sensor mode, by removing a sensor then running the motor to get the back upright should cure it

Thanks, I am just off to see him, I will let you know.

Alan
 

coolpot

Senior Member
Joined
Sep 4, 2006
Messages
186
Reaction score
0
Your Mercedes
c180/2002/1.8p
:Oops: ive heard this happens occasionally after windows have steamed up for some reason :)
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
331
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
:Oops: ive heard this happens occasionally after windows have steamed up for some reason :)

Yes the condensation drops onto the sensor, common fault when you are young:cool:
 
OP
alanuk400

alanuk400

Senior Member
Joined
Feb 2, 2006
Messages
215
Reaction score
1
Location
Belfast NI
Website
www.vipsec.co.uk
Your Mercedes
2016 W222 Mercedes S-Class LWB
  • Thread Starter
  • Thread starter
  • #9
I have a feeling that you will have to take it out, dismantle it and put it back together in the upright position.

I can provide you with some papers

Hi Malcom

Could you email me some papers, the garage hasn't started on it yet.:mad:

Thanks

Alan
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
331
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
I have sent the papers, found the E mail from your web site.

I have no details on what form the sensors or stops take, if a sensor blanking it off would work. The seat knows where it is in the memory as it counts the turns on the driving motor.

The end or limit switch must have failed or be bent
 
OP
alanuk400

alanuk400

Senior Member
Joined
Feb 2, 2006
Messages
215
Reaction score
1
Location
Belfast NI
Website
www.vipsec.co.uk
Your Mercedes
2016 W222 Mercedes S-Class LWB
  • Thread Starter
  • Thread starter
  • #11
Thanks Malcolm

What I am going to try tomorrow is to loosen the cogs so we can lift the seat back up, do you have the paper for the back of the seat so I can see where the bolts for motor are.

I can't blame the indie, he didn't want to spent hours on it just on speck.

Alan
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
331
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
What year is the car please up to 31-08-02 or after
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
331
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
OK its 03 need Email address again please
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
331
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
OK Alan and I will send it now
 
OP
alanuk400

alanuk400

Senior Member
Joined
Feb 2, 2006
Messages
215
Reaction score
1
Location
Belfast NI
Website
www.vipsec.co.uk
Your Mercedes
2016 W222 Mercedes S-Class LWB
  • Thread Starter
  • Thread starter
  • #16
Thanks

I have just spent all day stripping the seat, got the seat back up, now having difficulty putting it all back together
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
331
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Nothing that I can do to help there :(
 

3rab9

New Member
Joined
Mar 14, 2009
Messages
3
Reaction score
0
hi there ,i had a simular problem on my clk 320, my problem was that some of the motors were working but others were just clicking , after a little head banging i traced the fault to the fuse in the boot, there are on my car three fuse boxes and several different fuses for the seat, just check them all it should tell you on the fuse cover which fuses are which !!
hpoe this helps
mark..
 
OP
alanuk400

alanuk400

Senior Member
Joined
Feb 2, 2006
Messages
215
Reaction score
1
Location
Belfast NI
Website
www.vipsec.co.uk
Your Mercedes
2016 W222 Mercedes S-Class LWB
  • Thread Starter
  • Thread starter
  • #19
Hi

I checked the fuses before stripping, after stripping, the motor was working ok, just looks like something was stuck in the teeth.


Had to move the car with the seat out, guess what, SRS light came on:Oops:
Not my day at all.

Alan
 
Last edited:


Prestige Motor Group is Hertfordshire's Premier INDEPENDENT MERCEDES BENZ SPECIALIST. We offer a service exceeding Main dealership expectations and HUGE savings on Main Dealership Prices. WE BEAT ANY GENUINE QUOTE! Prestige Motor Group pride ourselves on delivering excellent customer service as we believe the customer and the Car deserve the best.
Tel: 01462 672458www.prestigemotorsofhertfordshire.co.uk/
Top Bottom