1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

E200 Problem Need Urgent Assistance

Discussion in 'Electrics, Vacuum, Ignition and ECU' started by Benzorama, Dec 15, 2009.

  1. Benzorama

    Benzorama New Member

    Messages:
    7
    Likes Received:
    0
    Joined:
    Dec 14, 2009
    Your Mercedes:
    Mitsubishi Evolution 5, 318i BMW, 523i BMW, E200, 68 Camaro
    Hi so I just bought an E200 1996 model Mercedes everything was fine for several hours I drove it and all was working. Once I left it for about 3 hours on the ferry and returned to drive it away it would not start.

    It turns over but wont ignite. I urgently need your help and really hope that I can sort this out because I am about 700km away from home and stuck here which cost me time, money for accommodation etc....

    General info:
    Model: W210
    Key: Flip up blade key (no spare key only the one with remote)
    First registered: Singapore
    Alarm: Pretty sure its factory MB (no stickers etc)


    The symptoms:

    1. Rear view mirrors red/green led alternate blinking when i put key into the iginition and turn to 2 position or try to crank.
    2. Red light blinks when car locks remote (without problems)
    3. Green light blinks when car is unlocked with remote (without problems)

    This is what I have tried so far:

    1. Disconnecting and reconnecting the battery (nothing)
    2. Resyncing the key by using numerous lock and unlock sequences with the remote
    3. Had it Scanned with error code something like ignition not permitted
    4. Replaced FOB batteries with new ones and repeated all the previous

    Possible solutions I have read about so far:
    1. Faulty K40 relay? (Am pretty sure its not it)
    2. Batteries dead? (not it)
    3. Ignition Keyring sticking out (its a bit loos but nothing unusual I think)
    3. I read on another forum that there is a tiny philips chip in the remote but when the technician opened the remote there was no such things, could this be possible the reason?

    I hope that there is a way to just disengage or bypass the immobilizer because at this stage I am pretty sure that except for that the only option is order a new key from factory in Germany. Which will take time and money I dont have.

    Please help I really want to go home
     
  2. C180 Chris

    C180 Chris Guest

    I had this problem with my S class and it just turned out to be fob batts, but i was told that under the passenger floor was the immob unit and it would be poss to override it by linking it out, ie it is the aftermarket looking box with a break in the loom so if you restore the loom back to orig it will link it out and start your car.........Well worth a look anyway.:D
     
  3. OP
    Benzorama

    Benzorama New Member

    Messages:
    7
    Likes Received:
    0
    Joined:
    Dec 14, 2009
    Your Mercedes:
    Mitsubishi Evolution 5, 318i BMW, 523i BMW, E200, 68 Camaro
    Thank you C180_Chris for your fast reply,

    I have undone the steel plate, there is a small box attached to it roughly 6cm long and 3cm wide/tall. Looks like some sort of a relay switch with a detachable plug on top, does that sound about right? cheers
     
  4. Steve@Avantgarde

    Steve@Avantgarde Forum Supporter Authorised Forum Supporter

    Messages:
    6,825
    Likes Received:
    1,003
    Joined:
    Dec 8, 2009
    Location:
    Bristol/Somerset
    Your Mercedes:
    C220CDI AMG Line Premium, SLR McLaren Roadster, SL55 & C32AMG
    hi

    could also be a fault with the mirror. It plays a major part in communicating what signals come from the key to the IFZ control module. if the mirror is faulty and its not telling the ecu to switch off the immob then it wont start.

    I have had plenty of these fail in the past.

    Steve
     
  5. OP
    Benzorama

    Benzorama New Member

    Messages:
    7
    Likes Received:
    0
    Joined:
    Dec 14, 2009
    Your Mercedes:
    Mitsubishi Evolution 5, 318i BMW, 523i BMW, E200, 68 Camaro
    Hi Steve,

    thank you very much for your suggestion, I need to consider all possibilities. How would I diagnose if it is the mirror are there any tests? cheers Marc
     
  6. television

    television Always remembered RIP

    Messages:
    164,074
    Likes Received:
    310
    Joined:
    Mar 14, 2005
    Location:
    Daventry
    Your Mercedes:
    2002 SL500, 216 CL500, all fully loaded
    I see as well that the early car can suffer interference from outside sunlight or artificial lights say on board a ferry,it is the interior motion sensor with and with out the mirror lamps flashing

    I will look further
     
  7. OP
    Benzorama

    Benzorama New Member

    Messages:
    7
    Likes Received:
    0
    Joined:
    Dec 14, 2009
    Your Mercedes:
    Mitsubishi Evolution 5, 318i BMW, 523i BMW, E200, 68 Camaro
    Hi Television, thank you for your insight, I wish I had your experience with Mercs. I do not believe I have an interior motion sensor or at least do not see one. The guys here reckon that it needs to exchange ECU, ignition relay and blade key/chip as they all work in conjunction. Any thoughts on this? cheers
     
  8. television

    television Always remembered RIP

    Messages:
    164,074
    Likes Received:
    310
    Joined:
    Mar 14, 2005
    Location:
    Daventry
    Your Mercedes:
    2002 SL500, 216 CL500, all fully loaded
    That is not correct,,if there was anything wrong with the key or associated parts it would not turn over. Your system is an early one and not all tied up with the engine ECU, all that is wrong is that the immobilizer is on.

    I will take a further look at the system and post back
     
  9. OP
    Benzorama

    Benzorama New Member

    Messages:
    7
    Likes Received:
    0
    Joined:
    Dec 14, 2009
    Your Mercedes:
    Mitsubishi Evolution 5, 318i BMW, 523i BMW, E200, 68 Camaro
    Ok, would you like me to provide you with chassis no would that help?
     
  10. television

    television Always remembered RIP

    Messages:
    164,074
    Likes Received:
    310
    Joined:
    Mar 14, 2005
    Location:
    Daventry
    Your Mercedes:
    2002 SL500, 216 CL500, all fully loaded
    No thats OK your car fall into the first early group,,there were no changed till 97-98
     
  11. OP
    Benzorama

    Benzorama New Member

    Messages:
    7
    Likes Received:
    0
    Joined:
    Dec 14, 2009
    Your Mercedes:
    Mitsubishi Evolution 5, 318i BMW, 523i BMW, E200, 68 Camaro
    Oh Just thought about one thing i havent mentioned, the fault code says something about ignition not permitted or something similar i think also "K54"
     
  12. television

    television Always remembered RIP

    Messages:
    164,074
    Likes Received:
    310
    Joined:
    Mar 14, 2005
    Location:
    Daventry
    Your Mercedes:
    2002 SL500, 216 CL500, all fully loaded
    The correct way to sync the key is to point the window of the remote control to the mirror in the car and press the large button on the remote twice and turn the key to position 2 within the next 30 seconds.


    To de sync the whole system before you do the above, disconnect the battery for 10 sec and then press the remote large button up to 100 times

    The k54 is the locking conformation relay

    Do you have an Email address where I can send something
     
  13. OP
    Benzorama

    Benzorama New Member

    Messages:
    7
    Likes Received:
    0
    Joined:
    Dec 14, 2009
    Your Mercedes:
    Mitsubishi Evolution 5, 318i BMW, 523i BMW, E200, 68 Camaro
    Yep I thought my email was visible sorry.

    Its: sooleetty@hotmail.com

    Thank you very much for your help. I have tried to point the key at mirror press twice and then put into ignition before but I havent tried to push over 100 times one yet. Do you think that the small plastic philips chip which is just loose in the remote could be the cause? cheers
     

Share This Page