1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

E220 fan problem

Discussion in 'Electrics, Vacuum, Ignition and ECU' started by michael101, Dec 9, 2012.

  1. michael101

    michael101 New Member

    Messages:
    5
    Likes Received:
    0
    Joined:
    Dec 8, 2012
    Location:
    cumbria
    Your Mercedes:
    2001 E220 cdi
    2002 E220. The fan is working fine but there is no air flow - hot or cold - out of the vents. Something stuck? In this weather quite happy to jam it full on if there's a way.
    Any solutions?
    Cheers
    Mike
     
  2. television

    television Always remembered RIP

    Messages:
    164,074
    Likes Received:
    310
    Joined:
    Mar 14, 2005
    Location:
    Daventry
    Your Mercedes:
    2002 SL500, 216 CL500, all fully loaded
    The car will have to go on STAR to see what has failed in the heater box, the flaps could need a re set.

    A good indie is the cheapest way to go
     
  3. OP
    michael101

    michael101 New Member

    Messages:
    5
    Likes Received:
    0
    Joined:
    Dec 8, 2012
    Location:
    cumbria
    Your Mercedes:
    2001 E220 cdi
    Cheers -also connected problem?

    Car also stuck in limp mode - had planned to get the diagnostic thing done - could they be connected?
    Should explain this is an old car -320K miles - had it from new - only does motorway driving and has been excellent except for bodywork. Running it until death but trying to keep it going a bit longer.
    Cheers
    Mike
     
  4. television

    television Always remembered RIP

    Messages:
    164,074
    Likes Received:
    310
    Joined:
    Mar 14, 2005
    Location:
    Daventry
    Your Mercedes:
    2002 SL500, 216 CL500, all fully loaded
    Been thinking, is the car a 210 for the heating in those is simpler, are all the fan speeds working, and no nothing to do with any limp home, That will need STAR,,,no reason not to keep it running
     
    Last edited: Dec 9, 2012
  5. OP
    michael101

    michael101 New Member

    Messages:
    5
    Likes Received:
    0
    Joined:
    Dec 8, 2012
    Location:
    cumbria
    Your Mercedes:
    2001 E220 cdi
    Type 210K

    the type is 210K - all fan speeds are working from off to high .... Would love to keep it running if it doesn't get too costly and falls apart - bodywork was a friday nighter.
    Mike
     
  6. lwbnick

    lwbnick Senior Member

    Messages:
    1,288
    Likes Received:
    0
    Joined:
    Mar 4, 2010
    Location:
    wales
    Your Mercedes:
    expedition
    Is your pollen filter blocked up with cack?
     
  7. OP
    michael101

    michael101 New Member

    Messages:
    5
    Likes Received:
    0
    Joined:
    Dec 8, 2012
    Location:
    cumbria
    Your Mercedes:
    2001 E220 cdi
    Where is the pollen filter located?

    Never changed the filter - don't know where it is - any pointers?
    Thanks for your help
    Mike
     
  8. whitenemesis

    whitenemesis Senior Member

    Messages:
    17,978
    Likes Received:
    22
    Joined:
    Dec 21, 2006
    Your Mercedes:
    CLS55 AMG '05
  9. bigasotonuk

    bigasotonuk Senior Member

    Messages:
    5,243
    Likes Received:
    9
    Joined:
    Nov 14, 2006
    Location:
    Southampton UK
    Your Mercedes:
    C43/55 AMG 1999 / C230K 1997
  10. OP
    michael101

    michael101 New Member

    Messages:
    5
    Likes Received:
    0
    Joined:
    Dec 8, 2012
    Location:
    cumbria
    Your Mercedes:
    2001 E220 cdi
    after dismantling everything...

    Took the filter out (finally found it underneath right next to the blower after taking out glove box, kick panels etc). You guys were right - air flow normal now. Thanks for your help.
    Mike
     

Share This Page