E320 terrible cold starting

bruces670

Senior Member
Joined
Oct 19, 2018
Messages
93
Reaction score
19
Your Mercedes
E320cdi 2008
Ok so as the title says my car is terrible starting on these cold mornings sometimes up to 10 mins of cranking! I’ve replaced the glow plugs which made no difference so now my thoughts have turned to the relay but I’ve heard people say this engine starts without them?

I also noticed that when doing the glow plugs I have several injector seals gone,I’ve considered this might contribute to the problem but if it’s a compression issue then wouldnt it be down on power when it’s running?

Ive also read that it could be something to do with air getting in the low pressure fuel lines?

TIA for any suggestions!
 

ajlsl600

Senior Member
Joined
Nov 18, 2013
Messages
8,812
Reaction score
5,777
Location
france
Your Mercedes
clk3202001,sl6002003 with everything regrettably sold ,A class 170cdi auto. NG/TF1800 ML250
What mileage
 
OP
B

bruces670

Senior Member
Joined
Oct 19, 2018
Messages
93
Reaction score
19
Your Mercedes
E320cdi 2008
  • Thread Starter
  • Thread starter
  • #3
162k
 

robin.large

Senior Member
Joined
Sep 11, 2019
Messages
394
Reaction score
342
Your Mercedes
CLS C63 AMG 2013
I'd think it sensible to fix any obvious issues. Such as any leaking seals. Also you don't say how cold? You may be based in Dubai? Canada? UK?
With leaking seals then the pressure will bleed out overnight for sure.

Sent from my ONEPLUS A5010 using Tapatalk
 

James Debuse

Senior Member
Joined
Oct 19, 2019
Messages
49
Reaction score
27
Your Mercedes
Mercedes e320 cdi estate w211
Mine has the same trouble. 2007 E320 cdi estate. Changed all glow plugs a short time ago when the light came on. Sorted that issue but still hates starting when cold. Runs fine when warm.
 

mersum1es

Senior Member
Joined
Sep 25, 2010
Messages
2,334
Reaction score
415
Location
Finland
Your Mercedes
W212/-09/350CDI, W219/-07/320CDI, EX:W220/-01/320CDI, EX:W211/-04/320CDI, EX:W210/-01/270CDI
excessive injector tank leak... what you mean by 'several seals gone'? Black death won't help, especially if you have cracked nozzle holder...
 
OP
B

bruces670

Senior Member
Joined
Oct 19, 2018
Messages
93
Reaction score
19
Your Mercedes
E320cdi 2008
  • Thread Starter
  • Thread starter
  • #7
Sorry I’m in the uk so it’s only been -3 ish at most
 
OP
B

bruces670

Senior Member
Joined
Oct 19, 2018
Messages
93
Reaction score
19
Your Mercedes
E320cdi 2008
  • Thread Starter
  • Thread starter
  • #8
excessive injector tank leak... what you mean by 'several seals gone'? Black death won't help, especially if you have cracked nozzle holder...

nozzle holder on the injector? That sounds expensive?
 

Wighty

Senior Member
Joined
Aug 4, 2016
Messages
13,212
Reaction score
12,139
Location
Sunny Essex
Your Mercedes
W211/E320cdi/2009 and CLK200k 2009
Mine has the same trouble. 2007 E320 cdi estate. Changed all glow plugs a short time ago when the light came on. Sorted that issue but still hates starting when cold. Runs fine when warm.
GP Relay Module changed buddy ? How old is the battery ?
 

mersum1es

Senior Member
Joined
Sep 25, 2010
Messages
2,334
Reaction score
415
Location
Finland
Your Mercedes
W212/-09/350CDI, W219/-07/320CDI, EX:W220/-01/320CDI, EX:W211/-04/320CDI, EX:W210/-01/270CDI
nozzle holder on the injector? That sounds expensive?
It is not. perhaps 20 quids, but it cause injector to leak usually on top of the engine too.
 

Uncle Benz

Senior Member
Joined
Mar 31, 2006
Messages
4,181
Reaction score
3,452
Age
52
Location
West Sussex
Your Mercedes
Mainly Mercedes
2008, you have an om642 v6 diesel. These will not start without the glow plugs. At 2008 it's very likely you have the early "fag packet" glow plug module. These are prone to failure. The updated part is a different shape and has a white back.
 
OP
B

bruces670

Senior Member
Joined
Oct 19, 2018
Messages
93
Reaction score
19
Your Mercedes
E320cdi 2008
  • Thread Starter
  • Thread starter
  • #12
E8171DC1-6E6D-4170-A160-4D5D0E93123F.jpeg
This is my relay/module
 

andrew056

Senior Member
Joined
Jun 7, 2010
Messages
118
Reaction score
19
Location
Devon
Your Mercedes
1993 SL320 gone but not forgotten , 2004 240 CLK cabrio, 2006 ML 320cdi gone, GLC AMG 43
It's nearly always the relay and that looks like the original so replace it and your car will start like new , I fitted a new one on my ML 320 many years ago , fixed the problem.
 

simmon01

Member
Joined
Jul 11, 2011
Messages
13
Reaction score
4
Location
Berkshire
Your Mercedes
E 270 CDI, E 220 CDI & C180 Estate E280 CDI
Id love to know what the result was, so many people come on asking for help and you don’t find out if you were any use to them. ‍♂️
 

Noddy 99

Senior Member
Joined
Aug 14, 2021
Messages
410
Reaction score
395
Location
Telford, Shropshire
Your Mercedes
2009 W211 E-Class E280 Sport Estate (OM642 3-litre diesel V6), 3x remapped, now returned to stock
Just noticed, I’m a ‘new member’ since 2011...
Yeah, but with your two posts today you're now up to 9 posts in 10 years. You'll soon be a "senior" like me, who's been here for 7 weeks...
 

Noddy 99

Senior Member
Joined
Aug 14, 2021
Messages
410
Reaction score
395
Location
Telford, Shropshire
Your Mercedes
2009 W211 E-Class E280 Sport Estate (OM642 3-litre diesel V6), 3x remapped, now returned to stock
Mine's just started to be a FRACTIONAL more hesitant; probably just normal but I'll keep an eye on it.

I've got a code-reader so, if it's either the relay or glow-plugs, would they throw a code?
 

Avantgarde Automotive, Mercedes-Benz and SLR McLaren specialists. Service, repairs, diagnosis and motorsport preparation.
Unit 14 Hither Green Trading Estate, Clevedon, Somerset, BS21 6XU Tel: 01275 217270 Email:steve@avantgarde-automotive.co.uk
www.avantgarde-automotive.co.uk
Top Bottom