faulty torque convertor???

clelly

Senior Member
Joined
Jan 10, 2007
Messages
137
Reaction score
0
Hi,
recently my c200 (2000 w202) has been playing up.When the engine is cold gears change no problem.Once they have warmed up they become tempremental and very sensitive to throttle control. If the car is in a low gear and I accelerate very gently then there is no problem,if however I accelerate more aggressively the car seems to lose power.The only way to cure this is to stop the car and restart it. It will then run fine untill the next time.
When this problem occurs and I stop to restart the car the engine appears to be reving slightly.
 
OP
C

clelly

Senior Member
Joined
Jan 10, 2007
Messages
137
Reaction score
0
  • Thread Starter
  • Thread starter
  • #3
Thanks for the speedy reply, I renewed the Maf just over a year ago, would it need replaced again so soon? Is there a way of testing to see if it is the maf thats faulty?
 

turbopete

Senior Member
Joined
Feb 4, 2009
Messages
14,209
Reaction score
329
Age
46
Location
Spennymoor
Your Mercedes
2017 '17' Ford Mondeo 2.0TDCi ST Line X 180 (sorry)
try unplugging it and see if that cures your problem.
 
OP
C

clelly

Senior Member
Joined
Jan 10, 2007
Messages
137
Reaction score
0
  • Thread Starter
  • Thread starter
  • #5
can I actually drive the car with the maf unplugged eg 2-3 miles down the road or do you mean just sit with the engine idling? thanks
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
341
Age
87
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
As Pete says, just unplug it and try the car, what make did you replace it with
 
OP
C

clelly

Senior Member
Joined
Jan 10, 2007
Messages
137
Reaction score
0
  • Thread Starter
  • Thread starter
  • #7
replaced it with a bosch from euro
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
341
Age
87
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
replaced it with a bosch from euro

That will be under guarantee then if it has failed,,give it a try unplugged, it may prove the point
 
OP
C

clelly

Senior Member
Joined
Jan 10, 2007
Messages
137
Reaction score
0
  • Thread Starter
  • Thread starter
  • #9
Hi,
Just driven the car with the maf unplugged but no difference. I did notice that when the car was idling the rev counter was sitting stable but the engine still sounded like it was reving slightly.
When accelerating the car was making a sort of whirring noise ( sounds strange I know)
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
341
Age
87
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Well I am lost on this,,see what others think and what to try
 

turbopete

Senior Member
Joined
Feb 4, 2009
Messages
14,209
Reaction score
329
Age
46
Location
Spennymoor
Your Mercedes
2017 '17' Ford Mondeo 2.0TDCi ST Line X 180 (sorry)
could be a slight split/perished vaccuum hose perhaps? air getting into the manifold, outting the ecu on alert of a lean mixture and cutting engine power? this would make the car rev slightly and make a strange noise! sorry i cant be of more help. this problem isnt one ive ever heard of before!
 
OP
C

clelly

Senior Member
Joined
Jan 10, 2007
Messages
137
Reaction score
0
  • Thread Starter
  • Thread starter
  • #12
torque convertor ???

Hi,
recently my c200 (2000 w202) has been playing up.When the engine is cold gears change no problem.Once they have warmed up they become tempremental and very sensitive to throttle control. If the car is in a low gear and I accelerate very gently then there is no problem,if however I accelerate more aggressively the car seems to lose power.The only way to cure this is to stop the car and restart it. It will then run fine untill the next time.
When this problem occurs and I stop to restart the car the engine appears to be reving slightly.

most recent development with the above problem occurs when I am sitting stationary with the engine running ( eg traffic lights ) the car wants to go forward of its own accord and judders slightly. To combat this I have been putting it into neutral and when lights change shifting it into drive. When I do this it takes a few seconds to catch and vibrates as I drive away. I know this is an unusual problem I just thought it was worth telling this development incase someone recognised the problem
many thanks
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
341
Age
87
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Engine mounts collapsed, throwing the drive train out of line
 
OP
C

clelly

Senior Member
Joined
Jan 10, 2007
Messages
137
Reaction score
0
  • Thread Starter
  • Thread starter
  • #14
Hi,
recently my c200 (2000 w202) has been playing up.When the engine is cold gears change no problem.Once they have warmed up they become tempremental and very sensitive to throttle control. If the car is in a low gear and I accelerate very gently then there is no problem,if however I accelerate more aggressively the car seems to lose power.The only way to cure this is to stop the car and restart it. It will then run fine untill the next time.
When this problem occurs and I stop to restart the car the engine appears to be reving slightly.

sorry to be harping on about this. whatever is going on, I thought the car was going into a safety type mode however it would appear that it is in fact firing on 3 cylinders.
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
341
Age
87
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Then how about a coil pack going down, they do break down more when under load
 
OP
C

clelly

Senior Member
Joined
Jan 10, 2007
Messages
137
Reaction score
0
  • Thread Starter
  • Thread starter
  • #16
hi malcolm thanks for your reply can you tell me more, would this cause the car to intermittantly fire on 3 cylinders
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
341
Age
87
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
hi malcolm thanks for your reply can you tell me more, would this cause the car to intermittantly fire on 3 cylinders

Yes it could,,coils and coil packs will often be OK at idle and low power but break down under load, like acceleration.

Worth just plugging into STAR at this stage to see what one, or what is going on
 

AIB understand your special Mercedes deserves a special insurance policy. We have a refreshing attitude to insuring high performance, modified, imported or classic and vintage cars and deal with the UK’s leading insurers. We offer discounts for length of ownership, where the vehicle is kept overnight and limiting the mileage and can also cater for those clients who need higher mileage and business use. To obtain a quotation please call the team on 02380 268351 or visit us atAIB Insurance
Top Bottom