Help

gypsy

New Member
Joined
Sep 29, 2009
Messages
6
Reaction score
0
Hi there, I am new to the forum and have always used it to help with my C220. Has anyone ever had the battery picture flashing saying there is a underlying problem. I checked the connections they seem ok but am starting to get worried because it is flashing red now. Any advice very welcome:confused:
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Welcome to the forum gypsy, what is the car please
 
OP
G

gypsy

New Member
Joined
Sep 29, 2009
Messages
6
Reaction score
0
  • Thread Starter
  • Thread starter
  • #3
Hi Malcolm, its a 2002 C class220 estate and I hate it now
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
These things happen,,and it could just be the regulator pack on the alternator,,, Maybe the car feels unloved and can sense that you hate it.

Do you have a good indie where you live
 
OP
G

gypsy

New Member
Joined
Sep 29, 2009
Messages
6
Reaction score
0
  • Thread Starter
  • Thread starter
  • #5
Haha, I think it knows I hate it when it plays up. I checked the car this pm and this is what it says "UNDERVOLTAGE SWITCH CONSUMERS OFF". Unfortunately I think I need to get a manual, I actually miss engines that you can just see and work at without all these silly covers and computers. Would love to swap my car for a scimitar, they my love
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
If the battery is poor and past its sell by date,,and the message "consumers off" goes away after a 10 minute drive,then the car is OK and just the battery coming to the end of its life.

If the car is driven daily, and this warning comes on every time, the maybe car not be going to sleep, and somrthing draining it
 
OP
G

gypsy

New Member
Joined
Sep 29, 2009
Messages
6
Reaction score
0
  • Thread Starter
  • Thread starter
  • #7
Hi again, the battery is only about a year old but worse news is that it has now got 6 problems, no electrics, and power is going was lucky to get home. I live in High Wycombe and am going to try and find someone who can help with Mercs. I have given up and rang the bloke who does the MOT and he is coming to pick it up and sort for me. Thank you so much for replying, will let you know how it goes.
 
Last edited:
A

andy@pcd-ltd

Guest
First thing to check would be is there a diesel leak at the front o the engine as this can cause the light to come on as the v belt will slip.
When you say you have no power do you mean the engine or the actual battery power.
Have you found someone to look at it yet for you
 
OP
G

gypsy

New Member
Joined
Sep 29, 2009
Messages
6
Reaction score
0
  • Thread Starter
  • Thread starter
  • #9
Thanks for that, garage bloke is coming to pick it up soon, I have a feeling that it might be the alternater (can't spell), just checked and the battery is not even a year old. Going to cost me AH!
 
A

andy@pcd-ltd

Guest
Ok cool because if you hadnt found anyone i as going to offer to come and have a look for you.
Let me know what he finds out
 
OP
G

gypsy

New Member
Joined
Sep 29, 2009
Messages
6
Reaction score
0
  • Thread Starter
  • Thread starter
  • #11
Hello all, I would just like to thank everyone for their help and advice. The car will be returned in the morning and it was the alternater (still can't spell), total cost is about £500 which includes labour and vat. There will be a large drink in this house to night.

Thank you again
 

You lost your key ? Or maybe you need a spare! Your vehicle imobilliser does not respond anymore? WE CAN FIX THEM ALL !! Mobile ! Save Time and Increase Profits With us !
Top Bottom