Horrid Ticking Sound and low power output - W210

kiwifraser

New Member
Joined
Nov 13, 2008
Messages
3
Reaction score
0
Our 1999 E240 Estate (W210) has a really loud clicking/ ticking noise when coming from the engine somewhere. It is similar in sound to a really badly set tappet. It is worst at cold startup, and everything is warmed up it quitens down. It can then come and go intermittantly, but does seem to disappear if driven hard for a while. My first thought was a sticking hydraulic lifter or cam follower, but don't know if it even has these.

We ran the car on the Surrey Rolling Road dyno, and although it was fuelling correctly on power runs, it was significantly down on power at circa 130HP instead of 170HP. The lambda may be faulty and the mixture was out at idle, but I have yet to find someone to run the fault codes for me. There have been no warning lights on the dash in the last few weeks, however prior to that it flashed up 'Oil sensor defective' a number of times.

Any ideas what the noise might be???
 

HERBIEMERCMAN

Senior Member
Joined
Dec 15, 2008
Messages
1,407
Reaction score
40
Location
PRESTON, LANCS.
Your Mercedes
97. E300.TD. 7 SEAT.ELEGANCE. EST.TOYOTA SUPRA MK4. RS. VAUX. CORSA.GLS AUTO. SPORT.
hi kiwi, like you i do not know if your car has a hydraulic valve lifting system, someone like malcolm (televisionman) might know, what i do know is that if the knocking noise was due to a little end bearing or any metal on metal bearing then the play and noise would not be intermittant as you describe.does your engine have a camshaft drive chain with the hydraulic tensioner? these can be noisy cold and back off when the engine is up to temperature. good luck. herbiemercman.
 
Last edited:

Comand Online Ltd is a specialist supplier of Mercedes Navigation Disks, Phone & Bluetooth, iPod, DAB, CD and other COMAND retrofit parts to enhance your vehicle.www.comandonline.co.uk
Top Bottom