information display within dashboard remaining on

wildmann

Member
Joined
Dec 31, 2010
Messages
18
Reaction score
0
Location
flintshire
Your Mercedes
c240 elegance 2001
Hi,

I'm a new member and I wonder if there is anyone out there who would be able to help me?

My problem is that I have drain on the battery, it has been identified as the display screen sited within the dashboard/display..It is the screen that provides info on blown bulbs, temp, time, milage etc.

Since Xmas day this section refuses to go out when the key is removed from the ignition. It dims slightly but that is it..

What do you think it is, what are the possible costs re repair and can I remove a fuse that will solve the problem short term??

I'd be very thankfull of any help or advice.
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Sadly I have little time to go into this, I take it it is a 1999 c240 that will be a 202,,,this could be a SAM fault,or ignition switch I. I doubt very much that it is the cluster, I hope that someone can help you on this
 
OP
W

wildmann

Member
Joined
Dec 31, 2010
Messages
18
Reaction score
0
Location
flintshire
Your Mercedes
c240 elegance 2001
  • Thread Starter
  • Thread starter
  • #3
Hi Malcom,

Many,many thanks for responding to my post. I have read many of your replies to previous posts with great interest..they are very informative. I recently had a new ignigtion switch..I say recently, it was around 3yrs ago; how quickly time flies, so, I hope that it's not that.
I was worried that it might be the cluster. The fact that it might be the sam also worries me...In general I'm worried! I'm going to book in for a diagnostic on Tues 4th Jan..fingers crossed I'm not looking at big bucks.

If you have any other ideas/thoughts please post..I'd be very grateful.

Once again many thanks.
 
OP
W

wildmann

Member
Joined
Dec 31, 2010
Messages
18
Reaction score
0
Location
flintshire
Your Mercedes
c240 elegance 2001
  • Thread Starter
  • Thread starter
  • #4
Please forgive the many spelling mistakes...it's what happens when you upload posts at midnight..especially at this time of the year :)

Happy New Year to all!!:D
 
OP
W

wildmann

Member
Joined
Dec 31, 2010
Messages
18
Reaction score
0
Location
flintshire
Your Mercedes
c240 elegance 2001
  • Thread Starter
  • Thread starter
  • #5
Informtion display within dashboard remaining on..resolved

Hi all,especially Malcom. You were spot on Malcom..it was the rear SAM unit. I've just had it replaced byan indi.Cost including fuel topup was 390.00. (was this reasonable?)

It's good to be back to normal.

Once again,many thanks for the help:)
 
OP
W

wildmann

Member
Joined
Dec 31, 2010
Messages
18
Reaction score
0
Location
flintshire
Your Mercedes
c240 elegance 2001
  • Thread Starter
  • Thread starter
  • #6
Here is the exact figs for the work..SAM £210, Labour £100, £62 vat..balance of fig for other minor jobs. All in all rather fair. I could have saved the labour and some of the vat if I had both better tech ability and time, but as I have neither, I'm pleased with the outcome.
 

Use the code MERCEDES and get 10% MBO Club Discount, oilman's website:www.opieoils.co.uk

register for news and offers email:sales@opieoils.co.ukphone: 01209 202944
Top Bottom