Instrument Cluster

mer500sel

Member
Joined
Jul 29, 2009
Messages
10
Reaction score
0
My 93 500SEL instrument cluster worked fine before it went in for a timing repair and now it won't reset?
Anyone with any ideas on how to get it to reset? The reset methodology won't work. Power to the cluster, but not in it, so nothing shows.
I hate to spend $1600 to get a new one. ( If I can get one even )
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Is it not worth having a word with those that did the work,,what part will not re set
 
OP
M

mer500sel

Member
Joined
Jul 29, 2009
Messages
10
Reaction score
0
  • Thread Starter
  • Thread starter
  • #3
Everything works, it's just there is no display on the dash.
Signals, lights, etc all work, but no display.
I find it hard to believe it could just quit like the Mechanic says they sometimes do.
Regardless, I was just informed the NEW instrument clusters are all digital read outs for replacement. Is this true? If I have to replace it, I'd like to replace with same.
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Then one from a breaker would do fine,, these things hardly ever fail
 

Alex Crow

Senior Member
Joined
Jul 9, 2009
Messages
10,677
Reaction score
40
Location
Super Suffolk
Your Mercedes
W169, W124, w202, W203, KTM 250 EXC, VW T25 camper and a Polo in a pear tree
no display? more specific please. is that no mileage display (but yours is analogue?), or no speedo, rev counter, gagues etc?
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
I am pleased that you do not understand either what is wrong
 

Alex Crow

Senior Member
Joined
Jul 9, 2009
Messages
10,677
Reaction score
40
Location
Super Suffolk
Your Mercedes
W169, W124, w202, W203, KTM 250 EXC, VW T25 camper and a Polo in a pear tree
i think our friend is from the usa, we are divided by a common language you know.

is this the one with that had the engine management light on? the workshop told him he needed a new timing chain - i believe. when it did not put the engine light out, they had a go at rigging the cluster to put the light out, and broke it. allegedly.

the above is just pure speculation, and i have no reason to believe this to be fact, it is probably just a simple co-incidence that the normally reliable cluster spontaneously failed.

mer500sel, i think they are BS-ing you about the reset. certainly on uk models this is not something that can be done or would need to be done on a 140 instrument cluster.
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Thanks and that comes back to me now :D
 
OP
M

mer500sel

Member
Joined
Jul 29, 2009
Messages
10
Reaction score
0
  • Thread Starter
  • Thread starter
  • #9
I agree with the BS part. All signs point to the Mechanic screwing up, and yes the timing issue was mine.
Just my opinion, but in dealing with Mercedes mechanics, I find them arrogant and self centered. They all seem to know what they are talking about until the problem isn't corrected, then the excuses fly like dust in the wind. I just want my car back, and in the same working order it went in. "No gauges, lights, odometer... nothing works on the dash"
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Then a second hand dash will do the job,,these are not coded to the car
 

Alex Crow

Senior Member
Joined
Jul 9, 2009
Messages
10,677
Reaction score
40
Location
Super Suffolk
Your Mercedes
W169, W124, w202, W203, KTM 250 EXC, VW T25 camper and a Polo in a pear tree
can concur, but it needs to be the same part number to be certain of compatibility.
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Thinking on this,,there is nothing to be lost by opening the cluster,,it is possible the track has been blown open circuit somewhere.

The tracks on the 129 cars can go open circuit with ease and they are almost the same cluster. I have repaired 3 of these for this fault
 

Alex Crow

Senior Member
Joined
Jul 9, 2009
Messages
10,677
Reaction score
40
Location
Super Suffolk
Your Mercedes
W169, W124, w202, W203, KTM 250 EXC, VW T25 camper and a Polo in a pear tree
yes indeed, they are almost the same and share some parts. guess he could post it to you malc?
 

AIB understand your special Mercedes deserves a special insurance policy. We have a refreshing attitude to insuring high performance, modified, imported or classic and vintage cars and deal with the UK’s leading insurers. We offer discounts for length of ownership, where the vehicle is kept overnight and limiting the mileage and can also cater for those clients who need higher mileage and business use. To obtain a quotation please call the team on 02380 268351 or visit us atAIB Insurance
Top Bottom