Intermittent loss of power

NoobOwner

New Member
Joined
Dec 28, 2020
Messages
2
Reaction score
0
Your Mercedes
2003 clk230
Hi all
2003 clk230 auto transmission

It’s fine on the motorway but in a stop start environment when I ease off on the accelerator the engine will drop to idle and won’t Rev no matter how far I push the pedal, if I lift off and push again it will drive fine... idle is smooth and engine starts fine just this intermittent loss of accelerator response (sometimes often)... it’s not the transmission slipping just no response from the engine... it’s kind of tricky round town
Any ideas? Cheers
 

onefortheroad

Senior Member
Joined
Dec 8, 2015
Messages
3,468
Reaction score
2,096
Location
uk.
Your Mercedes
Me -2019 GLC 350 coupe AMG line. Mrs- ford kuga 65 plate awd powershift .
Throttle pedal ??
 
OP
N

NoobOwner

New Member
Joined
Dec 28, 2020
Messages
2
Reaction score
0
Your Mercedes
2003 clk230
  • Thread Starter
  • Thread starter
  • #3
Thanks it could be? Not really familiar with these electronic systems been driving a van for years... thought it might be the TPS but doesn’t really seem to fit the symptoms of idle surges and lumpy idle that I’ve been reading... was hoping might be something that someone else had experienced
Weird thing is it drives normally when it picks back up it’s not really loss of power it’s intermittent loss of engine response
 


Comand (Europe) Ltd are the leading specialists in supplying and fitting Comand, Linguatronic, Media interface kits, UHI phone, IPod interfaces and much more.
Top Bottom