Light Throttle Misfire for the want of a better word !

vanmaster26

Senior Member
Joined
Dec 30, 2013
Messages
105
Reaction score
6
Location
cornwall u.k.
Your Mercedes
2009 ML 300 Sport
Hi Folk's can anyone tell me, if i can connect up my icarsoft i980 to my OM642 V6 3.0 Lt to shed any light on the above fault whilst driving,its not showing any fault codes,but pulling away in 1st i sometimes feel a little bit of a Misfire, i've done the usual changed Fuel Filter,Cleaned the MAF Sensors,Cleaned Air Filters K/N type,just wondered if i could pick something up with the software as i am not a Tech person

Many Thank's Kevin
 

Doug1234

Senior Member
Joined
Jun 28, 2009
Messages
934
Reaction score
257
Location
Bedfordshire uk
Your Mercedes
1997 w210 e300td
Heres my take on it but I may be wrong.
Stumbles when very light throttle applied from tick over , only the driver feels it as the throttle pedal movement does not give instant result expected ??.
Sounds familiar to me as my Jeep does it (same engine) and I reckon its the turbo actuator as mine has quite a bit of lost motion in the first part of its movement, only off tick over and the very slightest throttle input.
No codes or any info on my icarsoft bcc2.
My actuator arm has couple of mm slack either way on its movement.
 
OP
V

vanmaster26

Senior Member
Joined
Dec 30, 2013
Messages
105
Reaction score
6
Location
cornwall u.k.
Your Mercedes
2009 ML 300 Sport
  • Thread Starter
  • Thread starter
  • #3
Well Doug i don't know if i've solved the problem but i wanted to address the problem with ther Engine using Oil,so i have now done away with the PCV Pipe to the Air Filter Y-Pipe, and those rubbish orange Oil seals and gone down the road by cutting the Y-Pipe back and fitting a straight Silicone pipe doing away with the Oil coming in the side as it was and then the Hoover / Turbo sucking like there's no tomorrow drawing more oil from the PCV assy,anyway while the Y-Piece was off i removed the Air Filters and cleaned and re-oiled them removed the MAF sensors give them a clean also I've replaced the PCV and the rear Camshaft Oil Seal Carrier and now seems to be good at low revs i expect your Jeep will have a better set-up than Mercedes you won't have the rubbish design that Mercedes went for
 

You lost your key ? Or maybe you need a spare! Your vehicle imobilliser does not respond anymore? WE CAN FIX THEM ALL !! Mobile ! Save Time and Increase Profits With us !
Top Bottom