Limp mode again

philreed52

Senior Member
Joined
Jun 7, 2018
Messages
120
Reaction score
35
Your Mercedes
270clk
My 2005 CLK 270 cdi developed a fault of randomly going into limp mode .Came up with rail pressure fault ,had fuel filter change and all was well. Randomly it will lose turbo and worse if you kick it down hard and rev toward limit it cuts out. Turn key starts and runs fine management light on .start 4 time management light out.
Local garage can find nothing untoward or codes. Have MB indy 20 miles away so had him put on star No faults.Checked turbo operation all fine ,but he did say that turbo would not make it cut out anyway just lose power. Has put turbo and injector cleaner in as a trial to see if improves.
My inlet manifold has the dreaded leaking oily seals and would EGR valve clean and new manifold cure or help cure problem .wonder if flaps are sticking in egr or manifold ? The car has done 168k and apart from this intermittant loss of turbo runs beautifully (as long as you dont take it to the limit) there's a song about that !!
Any words of wisdom from any members would be appreciated.

Sent from my SM-G950F using Tapatalk
 

mioba

Senior Member
Joined
Feb 19, 2006
Messages
7,965
Reaction score
4,716
Location
Nottingham and Köln
Your Mercedes
W124/E200, W220/S320CDI, W205/C200, W251/R350CDI 4Matic
Could be actuator, when begin to fail they dont trigger codes
 

mioba

Senior Member
Joined
Feb 19, 2006
Messages
7,965
Reaction score
4,716
Location
Nottingham and Köln
Your Mercedes
W124/E200, W220/S320CDI, W205/C200, W251/R350CDI 4Matic
Not a fan of a mod to workaround an issue on a component that has failed and is there for a reason.

Turbos rarely fail and its always something linked to the turbo.

If you have leaking seals then change them, seals are there for a reason.
 

mersum1es

Senior Member
Joined
Sep 25, 2010
Messages
2,359
Reaction score
436
Location
Finland
Your Mercedes
W212/-09/350CDI, W219/-07/320CDI, EX:W220/-01/320CDI, EX:W211/-04/320CDI, EX:W210/-01/270CDI
Your local garage is roght, cutting out is caused by rail pressure. Boost line problem caus limp mode.

You said intake manifold leaking, did you check are the swirl flaps moving and all actuator arms on their place? Mine leaked through missing flaps/axle hole... try rev on stationary, you should see connecting link moving... then you need a 'dentist mirror' to check condition of all arms.

Dirty egr is one possible culprit, didn't you star mechanic tested it operation too (and SDS has swirl flap test too!)?
 
OP
P

philreed52

Senior Member
Joined
Jun 7, 2018
Messages
120
Reaction score
35
Your Mercedes
270clk
  • Thread Starter
  • Thread starter
  • #6
Your local garage is roght, cutting out is caused by rail pressure. Boost line problem caus limp mode.

You said intake manifold leaking, did you check are the swirl flaps moving and all actuator arms on their place? Mine leaked through missing flaps/axle hole... try rev on stationary, you should see connecting link moving... then you need a 'dentist mirror' to check condition of all arms.

Dirty egr is one possible culprit, didn't you star mechanic tested it operation too (and SDS has swirl flap test too!)?
The manifold is leaking oily mess so need to get it replaced are these aftermarket manifolds worth the money are they cheap for a reason ? My reasoning is if manifold is leaking it must be causing some anomalies within engine . I am quite mechanically minded but my experience is old school petrol engines with webbers etc. None of these fancy plug in bits lol
My thought is a second hand EGR make sure its clean and working and either new aftermarket manifold or genuine second hand one from prestige autoparts .My local garage will be doing work but I will prepare parts ready for them to fit. Trying to do this on a bit of a budget and trying to keep car off the road for shortest time ..Even if this does not sort it the job needs doing anyway.The car is clean and tidy and we want to keep it for a couple more years.
Really appreciate everyone's help


Sent from my SM-G950F using Tapatalk
 
OP
P

philreed52

Senior Member
Joined
Jun 7, 2018
Messages
120
Reaction score
35
Your Mercedes
270clk
  • Thread Starter
  • Thread starter
  • #7
Hi guys this fault is driving me mad .my 270clk has behaved for 4 weeks no limp mode since cleaner put in tank .Yesterday fault reared its ugly head no turbo eventually eml on turn off turn on turbo back 4 starts light out ,last time no codes .
It makes no sense.I have put post in wanted for 270 clk manifold to remove flaps and fit as I am sure it is related to this problem .2 garages have now tried to cure it and fault seems to go away short term but cannot work out what triggers it in normal quick driving on open road. If you pedal to metal from stationary it stalls but restarts immediately. Would flaps jamming cause that and other fault ?? One of the garages suggested leaking injector but again just a guess . It normally drives faultlessly until this problem occurs intermittently.

Sent from my SM-G950F using Tapatalk
 

Larkone

Senior Member
Joined
Aug 19, 2016
Messages
926
Reaction score
889
Location
NW Essex
Your Mercedes
C219 CLS 320CDI 2008
Sounds like the actuator - either get a refurb for about £90 or open it, carefully clean out the black carbon dust and re-grease the gears.
 

mersum1es

Senior Member
Joined
Sep 25, 2010
Messages
2,359
Reaction score
436
Location
Finland
Your Mercedes
W212/-09/350CDI, W219/-07/320CDI, EX:W220/-01/320CDI, EX:W211/-04/320CDI, EX:W210/-01/270CDI
You have to get decent coder reader and live data check... If it dies on flooring, it is 99% fuel pressure related. This WILL trigger fault code, and when it is easily repeated, you can check/log a live data about rail pressure to pinpoint it. If there is no code, that could be related to boost actuator problems, but then car thinks everytihing is fine but reaction to values is stalling it. Also MAF faults are not always triggereing codes, when silghtly faulty sensor.

Jamming flaps won't kill the engine, there are half of the holes still open. Faulty flaps do cause intermittent limp mode 100%
 

mattkh

Senior Member
Joined
Aug 2, 2006
Messages
3,170
Reaction score
354
Location
England
Your Mercedes
A160 W168 1999 1.6
....... No faults.Checked turbo operation all fine ,but he did say that turbo would not make it cut out anyway just lose power. Has put turbo and injector cleaner in. Any words of wisdom from any members would be appreciated.
Are there any additive turbo cleaners out there??
At that mileage, the EGR and the TURBO would definitely need a Mrmuscle Oven Foam cleaner treatment, not to mention the vacuum pipes.
 


Comand (Europe) Ltd are the leading specialists in supplying and fitting Comand, Linguatronic, Media interface kits, UHI phone, IPod interfaces and much more.
Top Bottom