1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Limp mode and EML light on.

Discussion in 'Engine, Drivetrain, Fuel and Exhaust' started by Robert McVinnie, Oct 17, 2020.

  1. Robert McVinnie

    Robert McVinnie New Registration

    Messages:
    1
    Likes Received:
    0
    Joined:
    Oct 17, 2020
    Your Mercedes:
    C220 CDI 2008
    Just wondering if anybody can help. My car is fine when driving normal. When you kick down the engine management comes on and goes into limp mode. Turn the engine off and limp mode goes off and EML stays on for a day. Changed fuel filter but same as. Does it on kick down and if I drop it with the manual shif + and - on the box. Plenty off power if not kicked down. No smoke, smells or misfiring. Thanks
     
  2. onefortheroad

    onefortheroad Senior Member

    Messages:
    1,572
    Likes Received:
    592
    Joined:
    Dec 8, 2015
    Location:
    uk.
    Your Mercedes:
    c207 e350 cdi 2017 . ford kuga 65 plate awd powershift .
    It needs a code scan otherwise your scratching your nuts.
     
  3. Dean Fletcher

    Dean Fletcher Senior Member

    Messages:
    2,586
    Likes Received:
    1,552
    Joined:
    Mar 24, 2018
    Location:
    Penrith, Cumbria
    Your Mercedes:
    Mercedes E250 coupe
    Same as above ^^^^^^
     
    Kev555 and Robert McVinnie like this.
  4. ajlsl600

    ajlsl600 Senior Member

    Messages:
    4,586
    Likes Received:
    2,098
    Joined:
    Nov 18, 2013
    Location:
    france
    Your Mercedes:
    clk3202001,sl6002003 with everything regrettably sold ,A class 170cdi auto. NG/TF1800 ML250
    To be honest wid u, as above the above!
     
    Kev555 and Robert McVinnie like this.
  5. Wighty

    Wighty Senior Member

    Messages:
    9,978
    Likes Received:
    7,034
    Joined:
    Aug 4, 2016
    Location:
    Sunny Essex
    Your Mercedes:
    W211/E320cdi/2009 and CLK200k 2009
    As above but without the nuts :rolleyes:
     
    Kev555, s5tuart, axelcls and 3 others like this.
  6. philreed52

    philreed52 Senior Member

    Messages:
    77
    Likes Received:
    19
    Joined:
    Jun 7, 2018
    Your Mercedes:
    270clk
    Got similar problem but no eml but hard kickdown would stall. took it to local indie merc specialist no faults showing .he suggested injector and turbo cleaner and to run on premium diesel. Tried this for couple of weeks and dont seem to be having problem .My MB is 270 cdi clk with 167k on clock .mine also use to randomly have no turbo .touch wood it has cured it
    He thought possibly dirty fuel had fowelled up an injector and this was cheap option to try start with .

    Sent from my SM-G950F using Tapatalk
     
    Dean Fletcher likes this.
  7. 00slk

    00slk Senior Member

    Messages:
    4,257
    Likes Received:
    2,692
    Joined:
    Dec 1, 2012
    Location:
    Cambridgeshire UK
    Your Mercedes:
    2002 SL55 AMG, 2009 SLK350, 2004 E320CDi
    I had a similar problem with our SLK 320, was diagnosed at my local Indy to a faulty MAF sensor. New one fixed the problem. The SL500 also had a similar problem and this too was a MAF Sensor, new one fixed that issue too.;)
     

Share This Page