ML 270 problems

Timwheatley

New Member
Joined
Jun 3, 2009
Messages
2
Reaction score
0
Hi. My first thread & I have a couple of issues with my 2005 ML270. First problem. The car starts fine from cold; however, occasionally when hot it will start OK but then cuts out after 10 seconds or so. It will fire up again after cranking for about 20 - 30 seconds. Once running its fine, no problems at all. I was advised to replace the battery in the key fob but this has not solved the problem. Any ideas?
Second issue. Rear suspension creak. When its cold or wet its fine. Now the warmer weather is here the rear suspension creaks when pulling away or coming to a stop. Once on the move its fine. Merecedes dealer said he couldn't find any problems but its very annoying to hear.
Obviously my ML doesn't like this warm weather..!!
Many thanks, Tim
 

Cole@MBS

Forum Supporter
Authorised Forum Supporter
Joined
Dec 1, 2008
Messages
13,615
Reaction score
748
Age
51
Location
Hedge End, Southampton
Website
www.mbssouthampton.co.uk
Your Mercedes
124 300 CE 24 Coupe, 209 240 CLK
Hi Tim, this sounds like a injector passing to much pressure into the spill pipe, a leak of test is the next step then on a star machine to read any fault codes and see the live data of the fuel system.

Welcome to the forums.
 
OP
T

Timwheatley

New Member
Joined
Jun 3, 2009
Messages
2
Reaction score
0
  • Thread Starter
  • Thread starter
  • #3
Thanks for that. I'll check with my local friendly garage. Any ideas regarding my creaky back end..!!:)
 


Specialist Car Insurance provider in the UK offering cheap car insurance quotes for all risks including Mercedes cars.
Top Bottom